Please help ……3G Connection problem ….

Home Page Forums Network Management ZeroShell Please help ……3G Connection problem ….

This topic contains 0 replies, has 0 voices, and was last updated by  hminkoong 9 years, 10 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #41920

    hminkoong
    Member

    Dear Guys

    I’ve successfully setup zeroshell on an Alix6B2 with a Sierra Wireless MC8780 but i can’t connect to 3G network.
    Eventhough i added user and password field to /root/kerbynet.cgi/scripts/3Gconnect (follow the step from this forrum http://www.zeroshell.net/eng/forum/viewtopic.php?t=1093&highlight=umts )
    , i still can’t connect to 3G Network.
    I also created file USERNAME and PASSWORD and placed them at /Database/var/register/system/net/interfaces/ppp0/ .
    I passed a SIM test by using this command ” comgt -d /udev/ttyUSB2″


    The Webgui configuration page



    This is 3Gconnect script

    #!/bin/bash
    . /etc/kerbynet.conf
    export PPP=”$1″
    [ -z “$PPP” ] && exit 1
    UNIT=${PPP:3:1}
    I=0
    PID=`ps -ef |grep -w pppd |grep $PPP| awk ‘{print $2}’`
    while [ -n “$PID” -a $I -lt 15 ] ; do
    kill $PID
    sleep 1
    I=$((I+1))
    PID=`ps -ef |grep -w pppd |grep $PPP| awk ‘{print $2}’`
    done
    if [ -n “$PID” ] ; then
    kill -9 $PID
    sleep 1
    rm -f /var/run/$PPP.pid
    fi
    TTY=”`cat $REGISTER/system/net/interfaces/$PPP/TTY 2>/dev/null`”
    if [ “$TTY” = NotDetected ] ; then
    exit 1
    fi
    APN=”`cat $REGISTER/system/net/interfaces/$PPP/APN 2>/dev/null`”
    DIAL=”`cat $REGISTER/system/net/interfaces/$PPP/Dial 2>/dev/null`”
    OPTIONAL=”`cat $REGISTER/system/net/interfaces/$PPP/Optional 2>/dev/null`”
    DEFAULTROUTE=”`cat $REGISTER/system/net/interfaces/$PPP/DEFAULTROUTE 2>/dev/null`”
    USERNAME=”`cat $REGISTER/system/net/interfaces/$PPP/USERNAME 2>/dev/null`”
    PASSWORD=”`cat $REGISTER/system/net/interfaces/$PPP/PASSWORD 2>/dev/null`”
    if [ -n “$OPTIONAL” ] ; then
    OPTIONAL=””OK” “$OPTIONAL””
    fi
    if [ -n “$APN” ] ; then
    APN=””OK” ‘AT+CGDCONT=1,”IP”,”$APN”,””,0,0′”
    fi
    if [ -n “$USERNAME” ] ; then
    USERNAME=”user $USERNAME”
    else
    USERNAME=””
    fi
    if [ -n “$PASSWORD” ] ; then
    PASSWORD=”password $PASSWORD”
    else
    PASSWORD=””
    fi
    if [ “$DEFAULTROUTE” == yes ] ; then
    DEFAULTROUTE=defaultroute
    else
    DEFAULTROUTE=””
    fi
    cat > /tmp/$PPP.3G < /tmp/$PPP.chat < /dev/null
    else
    $SCRIPTS/usb_modem_try.sh 2>/dev/null >/dev/null
    sleep 5
    if ! [ -r /udev/$TTY ] ; then
    logger -t pppd “ppp$UNIT: ERROR: Modem /udev/$TTY unavailable.”
    sleep 20
    fi
    fi
    fi
    sleep 10
    done



    This is my show log:

    Sep 14 23:14:19 hotspot pppd[9767]: pppd 2.4.3 started by root, uid 0
    Sep 14 23:14:21 hotspot pppd[9767]: Serial connection established.
    Sep 14 23:14:21 hotspot pppd[9767]: Using interface ppp0
    Sep 14 23:14:21 hotspot pppd[9767]: Connect: ppp0 < --> /udev/ttyUSB2
    Sep 14 23:14:22 hotspot pppd[9767]: CHAP authentication succeeded
    Sep 14 23:14:53 hotspot pppd[9767]: IPCP: timeout sending Config-Requests
    Sep 14 23:14:59 hotspot pppd[9767]: Connection terminated.
    Sep 14 23:14:59 hotspot pppd[9767]: Modem hangup
    Sep 14 23:15:00 hotspot pppd[9767]: Exit.
    Sep 14 23:15:10 hotspot pppd[10260]: pppd 2.4.3 started by root, uid 0
    Sep 14 23:15:11 hotspot pppd[10260]: Serial connection established.
    Sep 14 23:15:11 hotspot pppd[10260]: Using interface ppp0
    Sep 14 23:15:11 hotspot pppd[10260]: Connect: ppp0 < --> /udev/ttyUSB2
    Sep 14 23:15:12 hotspot pppd[10260]: CHAP authentication succeeded
    Sep 14 23:15:43 hotspot pppd[10260]: IPCP: timeout sending Config-Requests
    Sep 14 23:15:49 hotspot pppd[10260]: Connection terminated.
    Sep 14 23:15:49 hotspot pppd[10260]: Modem hangup
    Sep 14 23:15:50 hotspot pppd[10260]: Exit.
    Sep 14 23:16:00 hotspot pppd[10758]: pppd 2.4.3 started by root, uid 0
    Sep 14 23:16:02 hotspot pppd[10758]: Serial connection established.
    Sep 14 23:16:02 hotspot pppd[10758]: Using interface ppp0
    Sep 14 23:16:02 hotspot pppd[10758]: Connect: ppp0 < --> /udev/ttyUSB2
    Sep 14 23:16:03 hotspot pppd[10758]: CHAP authentication succeeded
    Sep 14 23:16:34 hotspot pppd[10758]: IPCP: timeout sending Config-Requests
    Sep 14 23:16:40 hotspot pppd[10758]: Connection terminated.
    Sep 14 23:16:40 hotspot pppd[10758]: Modem hangup
    Sep 14 23:16:41 hotspot pppd[10758]: Exit.



    This is a Chat log

    Sep 14 23:15:11 hotspot chat[10302]: abort on (BUSY)
    Sep 14 23:15:11 hotspot chat[10302]: abort on (NO CARRIER)
    Sep 14 23:15:11 hotspot chat[10302]: abort on (ERROR)
    Sep 14 23:15:11 hotspot chat[10302]: report (CONNECT)
    Sep 14 23:15:11 hotspot chat[10302]: timeout set to 15 seconds
    Sep 14 23:15:11 hotspot chat[10302]: send (AT^M)
    Sep 14 23:15:11 hotspot chat[10302]: expect (OK)
    Sep 14 23:15:11 hotspot chat[10302]: AT^M^M
    Sep 14 23:15:11 hotspot chat[10302]: OK
    Sep 14 23:15:11 hotspot chat[10302]: — got it
    Sep 14 23:15:11 hotspot chat[10302]: send (AT+CGDCONT=1,”IP”,”internet”,””,0,0^M)
    Sep 14 23:15:11 hotspot chat[10302]: expect (OK)
    Sep 14 23:15:11 hotspot chat[10302]: ^M
    Sep 14 23:15:11 hotspot chat[10302]: AT+CGDCONT=1,”IP”,”internet”,””,0,0^M^M
    Sep 14 23:15:11 hotspot chat[10302]: OK
    Sep 14 23:15:11 hotspot chat[10302]: — got it
    Sep 14 23:15:11 hotspot chat[10302]: send (ATD*99***1#^M)
    Sep 14 23:15:11 hotspot chat[10302]: expect (CONNECT)
    Sep 14 23:15:11 hotspot chat[10302]: ^M
    Sep 14 23:15:11 hotspot chat[10302]: ATD*99***1#^M^M
    Sep 14 23:15:11 hotspot chat[10302]: CONNECT
    Sep 14 23:15:11 hotspot chat[10302]: — got it
    Sep 14 23:15:11 hotspot chat[10302]: send ()
    Sep 14 23:16:01 hotspot chat[10761]: abort on (BUSY)
    Sep 14 23:16:01 hotspot chat[10761]: abort on (NO CARRIER)
    Sep 14 23:16:01 hotspot chat[10761]: abort on (ERROR)
    Sep 14 23:16:01 hotspot chat[10761]: report (CONNECT)
    Sep 14 23:16:01 hotspot chat[10761]: timeout set to 15 seconds
    Sep 14 23:16:01 hotspot chat[10761]: send (AT^M)
    Sep 14 23:16:01 hotspot chat[10761]: expect (OK)
    Sep 14 23:16:01 hotspot chat[10761]: AT^M^M
    Sep 14 23:16:01 hotspot chat[10761]: OK
    Sep 14 23:16:01 hotspot chat[10761]: — got it
    Sep 14 23:16:01 hotspot chat[10761]: send (AT+CGDCONT=1,”IP”,”internet”,””,0,0^M)
    Sep 14 23:16:01 hotspot chat[10761]: expect (OK)
    Sep 14 23:16:01 hotspot chat[10761]: ^M
    Sep 14 23:16:01 hotspot chat[10761]: AT+CGDCONT=1,”IP”,”internet”,””,0,0^M^M
    Sep 14 23:16:01 hotspot chat[10761]: OK
    Sep 14 23:16:01 hotspot chat[10761]: — got it
    Sep 14 23:16:01 hotspot chat[10761]: send (ATD*99***1#^M)
    Sep 14 23:16:02 hotspot chat[10761]: expect (CONNECT)
    Sep 14 23:16:02 hotspot chat[10761]: ^M
    Sep 14 23:16:02 hotspot chat[10761]: ATD*99***1#^M^M
    Sep 14 23:16:02 hotspot chat[10761]: CONNECT
    Sep 14 23:16:02 hotspot chat[10761]: — got it
    Sep 14 23:16:02 hotspot chat[10761]: send ()



    Did i miss somethings (i.e. AT or ATZ command)?

    Best Regards
    Hminkoong

    #48758

    hminkoong
    Member

    The problem has been solved. 🙂
    It’s caused by network operator (not my configuration).

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.