OpenVPN Server

Home Page Forums Network Management ZeroShell OpenVPN Server

This topic contains 0 replies, has 0 voices, and was last updated by  scegg 10 years ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #41643

    scegg
    Participant

    Hi.

    I just configured my zeroshell to enable OpenVPN followed http://www.zeroshell.net/eng/openvpn-server/.
    Auth mode: Only Password.

    And I installed a OpenVPN software on another computer. Follow section “The configuration file of OpenVPN” of http://www.zeroshell.net/eng/openvpn-client/ I created a config file and a ca file.

    I received this after I start openvpn client:

    Sun Apr 19 17:31:29 2009 OpenVPN 2.1_rc15 i686-pc-mingw32 [SSL] [LZO2] [PKCS11] built on Nov 19 2008
    Enter Auth Username:Allen
    Enter Auth Password:
    Sun Apr 19 17:31:33 2009 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
    Sun Apr 19 17:31:33 2009 NOTE: OpenVPN 2.1 requires ‘–script-security 2’ or higher to call user-defined scripts or executables
    Sun Apr 19 17:31:33 2009 LZO compression initialized
    Sun Apr 19 17:31:33 2009 Control Channel MTU parms [ L:1576 D:140 EF:40 EB:0 ET:0 EL:0 ]
    Sun Apr 19 17:31:33 2009 Data Channel MTU parms [ L:1576 D:1450 EF:44 EB:135 ET:32 EL:0 AF:3/1 ]
    Sun Apr 19 17:31:33 2009 Local Options hash (VER=V4): ’31fdf004′
    Sun Apr 19 17:31:33 2009 Expected Remote Options hash (VER=V4): ‘3e6d1056’
    Sun Apr 19 17:31:33 2009 Attempting to establish TCP connection with xxx.xxx.xxx.xxx:1194
    Sun Apr 19 17:31:33 2009 TCP connection established with xxx.xxx.xxx.xxx:1194
    Sun Apr 19 17:31:33 2009 Socket Buffers: R=[8192->8192] S=[8192->8192]
    Sun Apr 19 17:31:33 2009 TCPv4_CLIENT link local: [undef]
    Sun Apr 19 17:31:33 2009 TCPv4_CLIENT link remote: xxx.xxx.xxx.xxx:1194
    Sun Apr 19 17:31:33 2009 TLS: Initial packet from xxx.xxx.xxx.xxx:1194, sid=0e64cd1f 9af79b48
    Sun Apr 19 17:31:33 2009 WARNING: this configuration may cache passwords in memory — use the auth-nocache option to prevent this
    Sun Apr 19 17:31:34 2009 VERIFY OK: depth=1, /C=IT/O=Zeroshell.net/OU=Example/CN=Zer … oshell.net
    Sun Apr 19 17:31:34 2009 VERIFY OK: depth=0, /OU=Hosts/CN=zeroshell.example.com
    Sun Apr 19 17:31:35 2009 Data Channel Encrypt: Cipher ‘BF-CBC’ initialized with 128 bit key
    Sun Apr 19 17:31:35 2009 Data Channel Encrypt: Using 160 bit message hash ‘SHA1’ for HMAC authentication
    Sun Apr 19 17:31:35 2009 Data Channel Decrypt: Cipher ‘BF-CBC’ initialized with 128 bit key
    Sun Apr 19 17:31:35 2009 Data Channel Decrypt: Using 160 bit message hash ‘SHA1’ for HMAC authentication
    Sun Apr 19 17:31:35 2009 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 1024 bit RSA
    Sun Apr 19 17:31:35 2009 [zeroshell.example.com] Peer Connection Initiated with xxx.xxx.xxx.xxx:1194
    Sun Apr 19 17:31:36 2009 SENT CONTROL [zeroshell.example.com]: ‘PUSH_REQUEST’ (status=1)
    Sun Apr 19 17:31:36 2009 AUTH: Received AUTH_FAILED control message
    Sun Apr 19 17:31:36 2009 TCP/UDP: Closing socket
    Sun Apr 19 17:31:36 2009 SIGTERM[soft,auth-failure] received, process exiting

    How to fix this?
    I’m sure that user name “Allen” is created and password is right.

    #48032

    scegg
    Participant

    I use X509 mode to fix this..
    Only Password mode fail.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.