OpenVPN by Android

Home Page Forums Network Management VPN OpenVPN by Android

This topic contains 1 reply, has 0 voices, and was last updated by  Malik 3 years, 7 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #44465

    Malik
    Member

    Hello,

    I use it for several months Zeroshell VPN system using OpenVPN. This works fine with all of our PC. But today I have a problem with mobile phones running Android (Samsung).
    I utlise the OpenVPN application for Android. The connection is made but no data is passed. I have an error message in the log that indicates that the Zeroshell version of LZO is different.

    07:43:23 Re-using SSL/TLS context
    07:43:23 LZO compression initialized
    07:43:23 TCP connection established with 37.xxx.xxx.xxx:3404
    07:43:23 TCPv4_SERVER link local: [undef]
    07:43:23 TCPv4_SERVER link remote: 37.xxx.xxx.xxx:3404
    07:43:25 37.xxx.xxx.xxx:3404 [malik@WINSERVICE.FR] Trying Kerberos 5 (Local KDC) authentication
    07:43:25 37.xxx.xxx.xxx:3404 [malik@WINSERVICE.FR] Successfully authenticated
    07:43:25 37.xxx.xxx.xxx:3404 WARNING: ‘dev-type’ is used inconsistently, local=’dev-type tap’, remote=’dev-type tun’
    07:43:25 37.xxx.xxx.xxx:3404 WARNING: ‘link-mtu’ is used inconsistently, local=’link-mtu 1576′, remote=’link-mtu 1543′
    07:43:25 37.xxx.xxx.xxx:3404 WARNING: ‘tun-mtu’ is used inconsistently, local=’tun-mtu 1532′, remote=’tun-mtu 1500′
    07:43:25 37.xxx.xxx.xxx:3404 WARNING: ‘comp-lzo’ is present in local config but missing in remote config, local=’comp-lzo’
    07:43:25 37.xxx.xxx.xxx:3404 [malik] Peer Connection Initiated with 37.xxx.xxx.xxx:3404
    07:43:25 37.xxx.xxx.xxx:3404 [malik] Virtual IP automatically assigned: 172.16.15.10
    07:43:30 malik/37.xxx.xxx.xxx:3404 Bad LZO decompression header byte: 69
    07:43:35 malik/37.xxx.xxx.xxx:3404 Bad LZO decompression header byte: 42
    07:43:35 malik/37.xxx.xxx.xxx:3404 Bad LZO decompression header byte: 69
    07:43:37 malik/37.xxx.xxx.xxx:3404 NOTE: –mute triggered…

    And in the log of phone

    2015-12-17 10:07:51 OPTIONS IMPORT: route options modified
    2015-12-17 10:07:51 OPTIONS IMPORT: route-related options modified
    2015-12-17 10:07:51 OPTIONS IMPORT: –ip-win32 and/or –dhcp-option options modified
    2015-12-17 10:07:51 ROUTE_GATEWAY 127.xxx.xxx.xxx/255.0.0.0 IFACE=lo HWADDR=00:00:00:00:00:00
    2015-12-17 10:07:51 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
    2015-12-17 10:07:51 MANAGEMENT: >STATE:1450343271,ASSIGN_IP,,172.16.15.10,,,,
    2015-12-17 10:07:51 MANAGEMENT: CMD ‘needok ‘IFCONFIG’ ok’
    2015-12-17 10:07:51 MANAGEMENT: >STATE:1450343271,ADD_ROUTES,,,,,,
    2015-12-17 10:07:51 MANAGEMENT: CMD ‘needok ‘ROUTE’ ok’
    2015-12-17 10:07:52 MANAGEMENT: CMD ‘needok ‘ROUTE’ ok’
    2015-12-17 10:07:52 MANAGEMENT: CMD ‘needok ‘DNSSERVER’ ok’
    2015-12-17 10:07:52 MANAGEMENT: CMD ‘needok ‘PERSIST_TUN_ACTION’ OPEN_BEFORE_CLOSE’
    2015-12-17 10:07:52 Ouverture de l’interface tun:
    2015-12-17 10:07:52 IPv4 locale: 172.16.15.10/24 IPv6: null MTU: 1500
    2015-12-17 10:07:52 Serveur DNS: 172.16.15.1, 172.16.15.1, Domaine: null
    2015-12-17 10:07:52 Routes : 172.16.15.0/24, 172.16.16.0/24
    2015-12-17 10:07:52 Routes exclues : 88.xxx.xxx.xxx/32
    2015-12-17 10:07:52 Routes VpnService install├ęs : 172.16.15.0/24, 172.16.16.0/24
    2015-12-17 10:07:52 Disallowed VPN apps:
    2015-12-17 10:07:52 MANAGEMENT: CMD ‘needok ‘OPENTUN’ ok’
    2015-12-17 10:07:52 Initialization Sequence Completed
    2015-12-17 10:07:52 MANAGEMENT: >STATE:1450343272,CONNECTED,SUCCESS,172.16.15.10,88.xxx.xxx.xxx,1194,10.121.3.94,59445
    2015-12-17 10:07:56 write to TUN/TAP : Invalid argument (code=22)
    2015-12-17 10:08:01 write to TUN/TAP : Invalid argument (code=22)

    Can you help me solve this problem?

    thank you very much

    #53985

    redfive
    Participant

    Here there is a guide for openvpn ZS Android/IoS (thanks to fnc.gulino@libero.it), is in italian, take a look, if is a big problem the language, maybe I can help you with the config (mine is working with a minor changes from the above guide).
    Regards

    #53986

    Malik
    Member

    Redfive thank you for the quick response!

    I just spent the afternoon trying to translate this tutorial and attempted manipulation on my router but without success.
    I do not understand all the procedures and especially how to create a script from this document. I know already connect to Zeroshel using Putty but no more.

    I need support not to destroy my current VPN configuration !!

    Thank you

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.