No subnet declaration for ETH01

Home Page Forums Network Management ZeroShell No subnet declaration for ETH01

This topic contains 6 replies, has 0 voices, and was last updated by  billybolly 9 years, 10 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #41722

    billybolly
    Member

    Hello,

    Suddenly I get the message: (in the dhcpd log)
    “No subnet declaration for ETH01. If this is not what you want please write a subnet declaration in your dhcpd.conf file for the network segment to which interface ETH01 is attached.”

    And of course Zeroshell is not working.

    (In the settings I can see ETH01 192.168.1.1 and the subnet as 255.255.255.0)

    I have tried to find dhcpd.conf in zeroshell (with ssh) and failed !

    It is not in the etc directory.

    Any ideas?

    #48235

    yum
    Member

    Hi!

    dhcpd.conf in ZeroShell is created on the fly every time dhcp service is restarted. There’s no sense to edit it via ssh. Instead, you can use web interface.

    #48236

    billybolly
    Member

    Thank you for your answer.

    I am using the web interface and I see that ETH01 is correctly configured!

    The ip and subnet are: 192.168.1.1/255.255.255.0

    But I still see this message and zeroshell is not working!

    #48237

    e1iminator
    Member

    please describe your configuration so we

    #48238

    billybolly
    Member

    ETH00: 192.168.0.0 /255.255.255.0
    ETH01: 192.168.1.1/255.255.255.0

    #48239

    e1iminator
    Member

    eth0 should be 192.168.0.1 try it

    #48240

    billybolly
    Member

    this is not the problem

    #48241

    billybolly
    Member

    Problem solved !

    It was a problem of the adsl router! which I reseted.
    After reset, the address of dhcp server of the router was set to 192.168.1.100 automatically. So I changed the address of ETH01 to 192.168.1.100 and Everything works fine now!

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.