No MetadataProvider available.

Home Page Forums Network Management RADIUS 802.1x and Captive Portal No MetadataProvider available.

This topic contains 3 replies, has 0 voices, and was last updated by  ckoeber 6 years, 4 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #43132

    ckoeber
    Member

    Hello,

    When I try and enabled the captive portal I get this message when I test it out:

    Code:
    shibsp::ConfigurationException

    The system encountered an error at Mon Sep 26 16:47:27 2011

    To report this problem, please contact the site administrator at root@localhost.

    Please include the following message in any email:

    shibsp::ConfigurationException at (https://wireless.wesleyseminary.edu:12081/secure/cgi-bin/zscp)

    No MetadataProvider available.

    I am not sure what I am doing wrong. Below is my shibboleth2.xml file:

    Code:





    SAML2 SAML1


    SAML2 Local
















    What else do I need to do?

    Thank you for your time.

    Regards,
    Christopher Koeber

    #51965

    imported_fulvio
    Participant

    Are you sure you need to activate shibboleth for SAML authentication?
    Usually the captive portal has to be activated only with RADIUS/Kerberos authentication.

    Regards
    Fulvio

    #51966

    ckoeber
    Member
    fulvio wrote:
    Are you sure you need to activate shibboleth for SAML authentication?
    Usually the captive portal has to be activated only with RADIUS/Kerberos authentication.

    Regards
    Fulvio

    Thank you for your reply.

    You might be right.

    Here is our scenario. I have an external OpenLDAP/Radius system with our accounts. People need to be in this system for access to our wireless network.

    So I plan to have the ZeroShell system sitting between the wireless network and the internet + other resources that wireless clients need.

    So, I thought I needed the Shibboleth authentication mechanism but I just need Radius with the proxy stuff set up, correct?

    Thanks.

    #51967

    ckoeber
    Member
    fulvio wrote:
    Are you sure you need to activate shibboleth for SAML authentication?
    Usually the captive portal has to be activated only with RADIUS/Kerberos authentication.

    Regards
    Fulvio

    You were right. Only Radius authentication was needed for the initial setup I needed.

    Thanks.

    #51968

    sgoldman
    Member

    I was having a similar problem. I disabled the shibboleth auth and am just using RADIUS. However, I’m trying to use a RADIUS proxy and it doesn’t seem to be working. Is there a howto somewhere on this? I need something specifically for the RADIUS proxy setup.

    Thanks in advance.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.