Netbalancer with 2 Static Eth Interfaces? No PPoE/3G

Home Page Forums Network Management Firewall, Traffic Shaping and Net Balancer Netbalancer with 2 Static Eth Interfaces? No PPoE/3G

This topic contains 1 reply, has 0 voices, and was last updated by  knebb 5 years, 2 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #43885

    knebb
    Member

    Hi,

    I want to use Zeroshell as Internet LoadBalancer.

    I have two external Internet gateways. One is 192.168.2.254/24, the other is 192.168.200.19/24.
    Zeroshell can ping and arp both gateways without any issue.

    Having disabled NetBalancer and with just the single default gateway Internet access is running perfect.

    Now I’ve configured NetBalancer as shown in all of the docs. Seems to be pretty simple. Just add two gateways (one is the previous default gw) and enable NetBalancer.

    Unfortunately, it’s not working at all. 👿

    Having NB disabled I can ping from a local client any Internet host. As soon as I enable NB I’m getting from Zeroshell “ICMP Destination Host unreachable”. What I see on the external gateway nets is an ARP request from the Zeroshell to the Internet IP I’m trying to ping. Obviously this IP is an Internet IP and not in the local network so the arp reply is never answered- thus the above error message.

    It appears it doesn’t use any of the configured gateways. But why not? How can I troubleshoot to find the reason for the issue?

    Anyone having a hint?

    Thanks, Christian

    #53218

    DrmCa
    Participant

    This works in my configuration. Worked since 1.0b14 and now I am on 3.0.

    You can see my config in this thread: https://zeroshell.org/forum/viewtopic.php?t=4216 which I posted a while ago when L/B was not working very well. It is working now. Might want to reproduce it in your configuration and give it a try.

    #53219

    knebb
    Member

    @drmca wrote:

    This works in my configuration. Worked since 1.0b14 and now I am on 3.0.

    You can see my config in this thread: https://zeroshell.org/forum/viewtopic.php?t=4216 which I posted a while ago when L/B was not working very well. It is working now. Might want to reproduce it in your configuration and give it a try.

    Ok, thanks. I’ll test again.

    I’ll see how it is working…

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.