Netbalancer changes route too often => web banking broken

Home Page Forums Network Management ZeroShell Netbalancer changes route too often => web banking broken

This topic contains 3 replies, has 0 voices, and was last updated by  mark_orion 6 years, 8 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #41990

    mark_orion
    Member

    We notice in our network that certain web services do not work properly since we enabled the Zeroshell load balancer. These sites do not allow the route to change during a web session. They are mostly online banking sites, but even posting to this forum is causing trouble: I am always asked to login again and again whenever the Netbalancer sends my HTTP requests through a different gateway.
    Is there a way to create more “stickyness” in the net balancing system so that the route does not change at least within a reasonable amount of time (say 20 minutes)? Or is it possible to completely change the load balancing algorithm from session to IP based (host1 gets gateway1, host two gateway two, host three gets gateway1 again and so on)?
    I would prefer a general solution for this problem rather than setting up manual balancing rules for every machine or banking server.
    I am very grateful for any kind of help.

    #48961

    ppalias
    Member

    It has been reported again. For the time being adding a static route for the sites or a balancing rule for the internal IP addresses is the only way.

    #48962

    omicron
    Member

    Hi guys!

    I can see the thread was opened in 2009…
    Today, in 2012, there is no solution to resolve dinamically this issue using ZeroShell…

    The “solution” to add the IP address statically is not a good way because my users are using a lot of sites who need to maintain web sessions, and there is complicated to maintain a very large list of IP addresses…

    There is a real necessity to resolve this.

    If you have any idea, it would be welcomed.

    Thank you guys in advance!
    Regards 🙂

    #48963

    redfive
    Participant

    Hi orion , you could try with Atheling’s patch , seems fix the issue…
    http://www.zeroshell.net/eng/forum/viewtopic.php?t=3306&highlight=
    ciao

    #48964

    omicron
    Member

    Thank you!
    I will take a look 🙂

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.