Need help setting up work intranet

Home Page Forums Network Management Networking Need help setting up work intranet

This topic contains 3 replies, has 0 voices, and was last updated by  dantman 10 years, 8 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #41447

    dantman
    Member

    I’m attempting to use Zeroshell to setup a new intranet for my office at work.
    We used to have a setup with a FreeBSD server. It was setup by a former employee who was fired before I was hired (and judging by his setup of the server and how he programmed the software I was hired to completely rewrite I doubt his technical expertise). As well that router doubled as a development server (thus it was a plain box with DHCP and had no concept of port forwarding).
    So in short we’re trying to setup a new intranet using Zeroshell on the old box and using a separate machine as a new development server.

    I’ve read multiple documents, ran multiple searches on both google and this forum and haven’t been able to find information that helps me.
    For reference on what I do and do not know. I do understand enough to know about internal and external IP’s. But netmasks and subnets are a little fuzzy in definition.
    So consider me the “dummy” who doesn’t understand enough to figure out why he can’t get things to work, but understands enough that you won’t need to write a Wikipedia article sized post to get him to understand what a term means.

    I’ve loosely been using http://samiux.wordpress.com/2008/08/17/howto-home-made-wired-and-wireless-router-with-zeroshell/ and the PDF guide as references.
    For our network setup I’ll explain:

    We have one tower with two network cards which will act as our router. We are also reusing the switch that was part of the old network. For our internet the router is connecting directly to our Shaw high-speed modem.
    For now the only machine I am connecting into the switch other than the router is my own computer.

    I am able to connect to the Zeroshell web console configuring my computer with the static ip 192.168.0.1, and I have gotten far enough to setup a partition for zeroshell and create a database.
    I have followed the PDF guide in setting the static ip’s, setting the default gateway, and enabling NAT.
    I am unable to connect to the internet using my machine, moreover I cannot use the zeroshell router to ping or wget so I believe the issue lies in zeroshell not being able to connect to the outside internet.

    Under Setup > Network I have the information:
    ETH00 (This is the one connecting to the switch and thus my machine)
    Static ip: 192.168.0.75 with a netmask of 255.255.255.0
    ETH01 (This is the one that will be connecting to the outside internet)
    Static ip: 192.168.1.1 with a netmask of 255.255.255.0
    I have attempted turning on the DHCP and using the “Dyn.IP” option for ETH01 but it hasn’t helped me.

    NAT is enabled on ETH01

    I have attempted using both “192.168.0.75” and another IP on the same subnet as the “DEFAULT GATEWAY”.

    The routing table shown is:
    —-
    Destination: 192.168.1.0
    Netmask: 255.255.255.0
    Type: net
    Gateway: none
    Interface: ETH01
    Flags: U
    Source: Auto
    —-
    Destination: 192.168.0.0
    Netmask: 255.255.255.0
    Type: net
    Gateway: none
    Interface: ETH00
    Flags: U
    Source: Auto
    —-
    Destination: DEFAULT GATEWAY
    Netmask: 0.0.0.0
    Type: net
    Gateway: 192.168.0.75
    Interface: ETH00
    Flags: UG
    Source: Static
    —-

    #47553

    Dolphinus
    Member

    Your Gateway should be your Shaw high-speed modem’s IP address, that worked for me, I mean I had my satellite modem with an ip like 201.201.201.69 (not a real ip address) and my ETH01 with 201.201.201.70 ( cause my modem gives me a different, public and unrestricted ip address xD), so I used 201.201.201.69 as gateway and it worked really good for me ;D

    http://digilander.libero.it/smasherdevourer/schede/linux/zeroshellEN.pdf

    As you can see on that PDF your gateway must be on the same section as your ETH01 (If this is your external interface), on the PDF the ETH01 IP address is something like 192.168.1.1 and the gateway is 192.168.1.254..

    Hope it helps, I know what it is to be stuck in some configuration step and not finding any references on the internet.

    In less words your gateway address must be your Shaw high-speed modem’s IP address xD.

    Regards.

    #47554

    dantman
    Member

    To correct myself earlier, the other IP address I attempted using was “196.168.1.1”.

    I got ahold of the information shaw gave us. We have a static IP and they say we should be configured with the static IP “96.49.96.189” with the subnet mask “255.255.252.0” and the default gateway “96.49.96.1”.

    I have tried using this information but despite it I have been unable to get Zeroshell working.

    #47555

    imported_fulvio
    Participant

    The document http://digilander.libero.it/smasherdevourer/schede/linux/zeroshellEN.pdf by Cristian Colombini describes a network setup in which Zeroshell has been connected to Internet by using another router.
    Probably, instead, in your case you are using a Cable or xDSL modem (not a router). If so, Zeroshell must obtain an IP address directly assigned by your ISP. Ask if it is able to provide the connection by using PPPoE. In that case you have to create a PPPoE interface in Zeroshell and use it as default gateway. In addition, you do not require virtual server configuration because the PPPoE interface should be obtain a pubblic IP.

    Regards
    Fulvio

    #47556

    dantman
    Member

    Cable modem.
    PPPoE is not used by Shaw.
    Shaw uses either DHCP or a Static IP and the modem basically “Just Works” without needing to configure a MAC address or user information for the modem or machine.

    We have a static IP and as I noted in my previous post below Dlophinus’, I attempted to change my configuration of ETH01 to use the static IP and subnet mask that Shaw gave us, as well as setting the default gateway to the gateway that they gave us and I could not get Zeroshell to connect.

    I attempted directly using a direct IP address ping from Zeroshell to make sure there was no issue with DNS not working but I was unable to ping an outside server.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.