Need help configuring zeroshell as home router, gateway, WAP

Home Page Forums Network Management Networking Need help configuring zeroshell as home router, gateway, WAP

This topic contains 4 replies, has 0 voices, and was last updated by  knitatoms 7 years, 10 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #42239

    knitatoms
    Member

    Hello, I hope someone might be able to help me. I’ve looked through various docs and the forum but can’t find a clear way to achieve what I want.

    I have Zeroshell set up on an alix board. My plan is as per this image:

    Basically I would like zeroshell to be the gateway, router and wireless access point. I have ETH001 connected to a DSL modem (the modem is in bridge mode and I’ve added the connection details under new PPoE).

    I want Zeroshell to be the default gateway with IP address 192.168.1.254.

    I have the wireless card configured already on ETH002 as the box was previously working as a wireless access point. I’ve deleted the bridge it had with ETH00

    Now I want Zeroshell to replace my old router and become the router / gateway. Can you tell me step-by-step how to configure ETH00, ETH01, ETH02 and any bridges / NAT to get this all working please. I need clients to be able to connect to the internet through the Wireless card and also from the wire lan. I’ve been going round in circles!

    Thanks in advance.

    #49747

    ppalias
    Member

    It is not very hard! First from “System” -> “Setup” -> “Network” assign the IP address you want to the LAN and WIFI interfaces. If you want you may also bridge them to be in the same collision domain. In the same screen you setup the PPPoE to terminate your internet connection. To enable nat you need to go to “Network” -> “Router” -> “NAT” and move your newly created ppp0 to the NAT enabled interfaces.
    These steps give you a basic configuration to work with. Any other thing you want to do is documented here or in the documentation page.

    #49748

    knitatoms
    Member

    Excellent – thanks – it was just putting NAT on the ppp0 interface that I was missing – I had it on ETH01.

    All working now – many thanks!

    #49749

    micampo
    Member

    Please take a step by step to configure my adsl modem with my zs

    #49750

    ppalias
    Member

    micampo,
    it depends on the configuration you want to do to your setup. Who will be terminating the PPPoE? ADSL modem-router or the ZS?

    #49751

    Anonymous
    Member

    DELETED

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.