named issue in 2.0RC1

Home Page Forums Network Management ZeroShell named issue in 2.0RC1

This topic contains 0 replies, has 0 voices, and was last updated by  SilverFalcon 6 years, 6 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #43408

    SilverFalcon
    Member

    Hi,

    I have just built a unit on 2.0RC1 in the same manner I have done previously with 1.0b16.

    In the DNS forwarders I am using the ANY domain and two IPs for DNS servers. This works fine until the server is rebooted.

    After reboot I can no longer do DNS lookups to localhost I just get an NXDOMAIN returned. If I disable and re-enable DNS from the WebUI or run named from the Shell DNS lookups then start working again.

    I’ve tried calling named from the postboot script which didn’t work.
    I also tried making postboot remove the symlink to /etc/named.conf and recreating before calling named which also didn’t work.

    I have some postboot scripts which copy settings down from a central location and these no longer work as the DNS names cannot be resolved.

    I would appreciate if someone else can see if they can reproduce this bug.

    Regards,

    Phill

    #52412

    SilverFalcon
    Member

    I’ve noticed that if I put a sleep for 120 seconds at the top of my pre-boot script. All commands that run subsequently which require DNS lookup will work.

    They don’t work with a sleep of 60 seconds or less.

    I’m wondering if there is something in the new kernel which is causing a delay in loading the named config from /Database?

    Cheers,

    Phill

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.