Multi vlan dhcp configuration

Home Page Forums Network Management Networking Multi vlan dhcp configuration

This topic contains 0 replies, has 1 voice, and was last updated by  alsterb 5 months, 1 week ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #64079

    alsterb
    Participant

    I’m having difficulties getting the dhcp to work in a multi-vlan configuration. I’ve configured IP-Helpers on my router interfaces, pointing to a single interface (Eth01) on my ZeroShell server. The server is NOT located in any of the networks/vlans that need dhcp.

    Configured native IP on Eth01 (address that my IP-Helpers point to)
    Added a vlan X to Eth01 (UP)
    Added an IP range to vlan X (UP)
    Created a DHCP scope associated with Vlan X (Active)
    DHCP does not give out addresses….

    Prior versions of ZeroShell (3.4.0), we found a work around by unchecking (disabling??) the IP range associated with the vlan, but leaving the vlan checked (up/enabled) on the Setup/network section/tab. Even though the DHCP screen does not seem happy (“DHCP Service is not active…”), the scopes are giving out addresses….

    Every once an awhile, my test device will magically get an IP, but as I continue to work on the configuration, I’ll somehow break it. Removing the last thing I did does NOT fix it. I can not figure out how it works when it does and I can not figure out why it breaks.

    Is there something I’m missing? Like I said, I have another box running ZeroShell 3.4.0 and this one is giving out addresses to multiple vlans/networks. I didn’t want to downgrade my 3.9.0 box, but so far that looks like my only recourse.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.