MRTG Won’t Run in ZS 3.1.0

Home Page Forums Network Management Signal a BUG MRTG Won’t Run in ZS 3.1.0

This topic contains 1 reply, has 0 voices, and was last updated by  millap 4 years, 11 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #44022

    millap
    Member

    Hi All,

    I’ve installed ZS on a Dell R210, having modified the 3.1.0 ISO to include the on-board bnx2 nic firmware fw file.

    All is well so far with the install except MRTG.

    ‘service mrtg start’ doesn’t return anything

    ‘service mrtg status’ returns

    root@zeroshell bin> service mrtg status
    MRTG is not running

    When manually running the mrtg command from /cdrom/usr/local/mrtg-2/bin, I get –

    Can’t locate loadable object for module File::Glob in @INC (@INC contains: /cdrom/usr/local/mrtg-2/bin/../lib/mrtg2 /cdrom/usr/local/mrtg-2/bin /usr/lib/perl5/site_perl/5.18.1/i586-linux /usr/lib/perl5/site_perl/5.18.1 /usr/lib/perl5/5.18.1/i586-linux /usr/lib/perl5/5.18.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at /cdrom/usr/local/mrtg-2/bin/../lib/mrtg2/MRTG_lib.pm line 470.
    Compilation failed in require at /cdrom/usr/local/mrtg-2/bin/../lib/mrtg2/MRTG_lib.pm line 470.
    BEGIN failed–compilation aborted at /cdrom/usr/local/mrtg-2/bin/../lib/mrtg2/MRTG_lib.pm line 470.
    Compilation failed in require at mrtg line 89.
    BEGIN failed–compilation aborted at mrtg line 89.

    The first indication of this issue is when attempting to view the stats from System Load statistics, which returns –

    Not Found

    The requested URL /mrtg/system.html was not found on this server.

    Regards
    millap

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.