Login via LDAP Browse/Administrator

Home Page Forums Network Management ZeroShell Login via LDAP Browse/Administrator

This topic contains 2 replies, has 0 voices, and was last updated by  Noisy1 9 years, 10 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #41600

    Noisy1
    Member

    Hello! This is likely a simple question given I am a newbie. 😳

    I recently installed a virtual machine to run zeroshell (1.0 beta11). I can login via firefox and I created a new profile. I can also login via LDAPAdmin (on a WinXP machine) anonymously and I can browse through the LDAP DIT. However, I cannot login using authentication!!

    Here is what I am using…

    Username: uid=admin,ou=People,dc=testing,dc=com
    Password : (the same one I login via the web)

    I´ve manualy re-entered the password for admin via the web interface through the USERS|EDIT screen and through the KERBEROS 5|EDIT screen, but still no luck.

    I have nothing loaded on this test VM, so I can easily recreate it if necessary.

    Thanks for your help!

    #47920

    DWarg
    Member

    @noisy1 wrote:

    Hello! This is likely a simple question given I am a newbie. 😳

    I recently installed a virtual machine to run zeroshell (1.0 beta11). I can login via firefox and I created a new profile. I can also login via LDAPAdmin (on a WinXP machine) anonymously and I can browse through the LDAP DIT. However, I cannot login using authentication!!

    Here is what I am using…

    Username: uid=admin,ou=People,dc=testing,dc=com
    Password : (the same one I login via the web)

    I´ve manualy re-entered the password for admin via the web interface through the USERS|EDIT screen and through the KERBEROS 5|EDIT screen, but still no luck.

    I have nothing loaded on this test VM, so I can easily recreate it if necessary.

    Thanks for your help!

    Use “manager”…

    manager user shares the password with admin.

    #47921

    Noisy1
    Member

    @dwarg wrote:

    Use “manager”…

    manager user shares the password with admin.

    Nope. Same result. Just to reiterate, I tried both

    uid=manager,ou=People,dc=testing,dc=com
    uid=admin,ou=People,dc=testing,dc=com

    I actually, re-created the profile, restarted zeroshell, activated the new profile and still the same results with both admin and manager. I can login anonymously without a problem, but I cannot bind (login with authentication) to zeroshell. I get an

    LDAP error: Invalid Credentials!

    This is with WinXP´s LDAPAdmin, but I am also having connectivity issues with my zeroshell instance from where I really want to use it, a Plone instance.

    I welcome other suggestions. THANKS!

    #47922

    Noisy1
    Member

    Maybe my problem is even more basic. Maybe I am not setting zeroshell correctly to serve LDAP. I cannot find any documentation, FAQs or How-To on the steps that are required to set it up.

    Is there a guideline I can follow? Did I miss the documentation somewhere?

    Here is what I did:

    1. create a data store
    2. create a new profile…
    3. I filled in the description
    4. corrected the hostname to look like ldap.testing.com
    5. made sure the Kerberos Realm matches the domain, TESTING.COM
    6. ensured the LDAP base is dc=testing,dc=com
    7. set a new password
    8. clicked Create
    9. I then Activate the new profile
    10. I don’t know if my zeroshell machine is restarting automatically every time I activate a different profile, but I know it did restart last time I did
    11. then I go to LDAP/NIS, check LDAP and LDAP over SSL and click Save

    Am I missing something?

    Thanks!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.