Login to the GUI

Home Page Forums Network Management ZeroShell Login to the GUI

This topic contains 8 replies, has 0 voices, and was last updated by  proberts 12 years, 4 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #40505

    proberts
    Member

    How do I login to the GUI?

    I note the server screen says admin / zeroshell and the FAQs say that and a response in the forum says that as well…

    However, it does not work. Just keeps saying Login Failed!!!

    Any ideas? 1.0.beta2. I’m using Firefox 2.0 if that matters.

    Thanks.

    #44973

    proberts
    Member

    Maybe this bit of info helps:

    I can’t change the admin password from the server either.

    I get a kpasswd: cannot contact any KDC error of some sort.

    #44974

    imported_fulvio
    Participant
    proberts wrote:
    Maybe this bit of info helps:

    I can’t change the admin password from the server either.

    I get a kpasswd: cannot contact any KDC error of some sort.

    Using the console, post the output of the following commands:

    ping 192.168.142.142
    ping KDC.localdomain
    kinit admin

    Regards
    Fulvio Ricciardi

    #44975

    proberts
    Member

    I get no response from the IP or the hostname.

    I get the Cannot contact any KDC… error on the kinit.

    Is this because I had to use another IP address for the server? I saw another post that stated the IP had been changed but I think you didn’t mention that was the issue.

    I did a dhclient to get an IP on my network.

    I have an odd ifconfig:

    ETH00 192.168.1.206 –< I get to the admin web GUI here.
    ETH00:00 192.168.0.75 –< I thought I overwrote that with DHCP but instead it added :00

    Is there a proper way to grab a dhcp or assign a static that will work on my subnet?

    Thanks.

    #44976

    imported_fulvio
    Participant

    Please, send me the output of the following commands:

    ifconfig
    route -n

    Bye
    Fulvio

    #44977

    proberts
    Member

    Is there an easy way to copy the ifconfig? It’s lengthy and I can’t SSH to the server.

    Changing the IP address by using dhclient to get a DHCP address is the issue because I can change the admin password before I cange the IP and not after.

    route shows:

    192.168.1.0 GW 0.0.0.0
    192.168.0.0 GW 0.0.0.0
    0.0.0.0 GW 192.168.1.101
    All on ETH00

    ifconfig is basically:

    DEFAULTBR no IP
    ETH00 192.168.1.206
    ETH00:00 192.168.0.75
    dummy0 no IP
    dummy1 no IP
    lo 127.0.0.1

    So, the difference I see is that I think the dummy used to be the IP subnet you gave me for the KDC….after the dhclient it looks like it resets the dummy0 so there is no longer an associated IP?

    Thanks for the help!

    #44978

    imported_fulvio
    Participant

    @proberts wrote:

    Is there an easy way to copy the ifconfig? It’s lengthy and I can’t SSH to the server.

    For security reasons, the SSH daemon is disabled, but using the console you can enable it by typing the command:

    service sshd start

    Only root is able to open a remote shell because I have not configured the PAM yet. You will have to change the root’s password with the command

    passwd
    @proberts wrote:

    Changing the IP address by using dhclient to get a DHCP address is the issue because I can change the admin password before I cange the IP and not after.
    So, the difference I see is that I think the dummy used to be the IP subnet you gave me for the KDC….after the dhclient it looks like it resets the dummy0 so there is no longer an associated IP?

    Ok, you are right. After you issue the dhclient command, use the following command:
    ifconfig dummy1 192.168.142.142
    This IP address is used for local authentication by apache and console process because the Kerberos MIT KDC does not issue ticket for 127.0.0.1 requests.

    #44979

    proberts
    Member

    Thanks!

    That did the trick. Looks good so far.

    #44980

    kikodog
    Member

    always login error in gui why??? thanks in advance.

    #44981

    kikodog
    Member

    i have read all post thanks 😛 now i can acess heheeh 🙂

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.