Load Balancing and Banking

Home Page Forums Network Management ZeroShell Load Balancing and Banking

This topic contains 2 replies, has 0 voices, and was last updated by  Atriasys 4 years, 4 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #43991

    Atriasys
    Member

    Hi there,

    I have been using Zeroshell (in a VMware machine) since version 2 – I originally got it to provide my customer with load balancing across their 3 internet connections. However I quickly found out that the users could not access banking or other sites that used security – I guess because they try to send a response to the originating IP address.

    I have upgraded to version 3.0 and I still have the same problem.

    Can someone please assist me with setting up the balancing rules so the banking sites work?

    I have previously tried setting a rule for port 443 to go through only 1 connection – but that didn’t work for some reason.

    eg:
    MARK tcp opt — in * out * 0.0.0.0/0 -> 0.0.0.0/0 tcp dpt:443 MARK set 0x66

    #53387

    redfive
    Participant

    Are you using also the proxy, in addition to the load balancing ?
    Regards

    #53388

    Atriasys
    Member

    Hi there,

    In my example above – no I wasn’t using the proxy – however my customer wants now to also block access to certain sites and I understand the proxy is the way to do this – so I will be turning it on.

    #53389

    Atriasys
    Member

    Can anyone assist me with this please?

    I have turned on NAT for the interface (Only 1 interface used ETH0)

    When I turn on any more than 1 connection to active – users lose all ability to access the Web.

    I must be doing something wrong – I just can’t figure it out – I will post a network diagram also.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.