Load Balancing

Home Page Forums Network Management ZeroShell Load Balancing

This topic contains 2 replies, has 0 voices, and was last updated by  fnmunhoz 10 years, 7 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #41093

    fnmunhoz
    Member

    I am trying configure zeroshell with 2 (or more) providers. I have the same enviroment of the the figure:

    http://tldp.org/HOWTO/Adv-Routing-HOWTO/lartc.rpdb.multiple-links.html

    I dont’t know if is possible configure it directly in Zeroshell web interface, so I do by SSH.

    The ‘Split access’ explained in the HOWTO works fine, no erros, but when I try execute the command of the ‘Load balancing’ section I got a error:

    root@zeroshell:~# ip route add default scope global nexthop via 192.168.10.1 dev ETH02 weight 1 nexthop via 10.1.1.1 dev ETH01 weight 1
    RTNETLINK answers: Invalid argument

    My network configuration is:

    ETH01:

    IP: 10.1.1.200
    NET: 255.255.255.0
    GW: 10.1.1.1

    ETH02:

    IP: 192.168.10.99
    NET: 255.255.255.0
    GW: 192.168.10.1

    The ETH00 is the internal interface

    What I should do to Load Balance works in zeroshell ?

    #46657

    imported_fulvio
    Participant

    What release of Zeroshell are you using? only the latest release (1.0.beta10) has the Kernel with the multi path routing enabled.
    In any case, starting with next release (1.0.beta11) will be possible to configuring failover and load balancing of the WAN link by using the web interface.

    Regards
    Fulvio

    #46658

    fnmunhoz
    Member

    I am using Zeroshell 1.0.beta9. I am going to upgrade to next version and try again.

    thanks.

    When are you planning to release the 1.0beta11?

    #46659

    imported_fulvio
    Participant

    On September I am going to release it.

    Regards
    Fulvio

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.