Load Balance with DHCP Not working

Home Page Forums Network Management ZeroShell Load Balance with DHCP Not working

This topic contains 3 replies, has 0 voices, and was last updated by  meluvalli 4 years, 10 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #43636

    meluvalli
    Member

    Hello. I have setup load balancing and everything works. However, the only way I was able to get it to work is to setup my gateways manually under NET BALANCER/Gateway List.

    If I select the actual Interface instead of putting in the gateway’s, the server can’t get on the internet.

    Is this a known glitch n ZeroShell? Wouldn’t be a problem with I had all static IP addresses, but one of my interfaces has DHCP 🙁

    Thanks!

    #52723

    m_elias
    Member

    I found the same thing, seems to be a bug.

    #52724

    sball
    Member

    Hello! Is this still the case? I can’t seem to get ZS to loadbalance my WAN-connections (which is all unfortunately DHCP).

    #52725

    DrmCa
    Participant

    Mine is working and all I had to do was add ppp0 and ppp1 under the gateway with the same weight of 1, then enabled them and disabled default GW.

    Did you make sure that net balancer is enabled (Status: Active and mode is Load balanding and Failover)?

    #52726

    sball
    Member

    Well, I don’t have an Cable Modem or anything like that, so I can’t really use pppoe, since I guess my ISP won’t accept it(?)

    I have a switch from my ISP which has 4 ports with 100mbit full duplex each. I’d like to loadbalance those WAN-connections. Sadly, I can only obtain public IP’s via DHCP, and all NIC’s seem to use the same gateway. I can’t type in the IP’s, since they all use the same gateway, thus it will only balance trough a single interface.

    If I instead select the interfaces in the gateway-list, it will simply say Failed on each item in the gateway-list. 🙁

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.