Level 7 filter on 3.0.0

Home Page Forums Network Management ZeroShell Level 7 filter on 3.0.0

This topic contains 15 replies, has 0 voices, and was last updated by  maccowley 4 years, 4 months ago.

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #43851

    maccowley
    Member

    I installed Zeroshell on a Zotac with an AMD-350 and it runs very well except of the level 7 filters.

    I would like to setup a bridge for QOS like described in https://www.zeroshell.org/qos/. This should enhance the quality of our VOIP calls. The bridge works fine, but I couldn’t get the L7 filters running. I tried several of them like VOIP, Skype, FTP,.. without any results. I have made a special test class to monitor the effects without success.
    When I look at the processor load I am pretty sure that there is no L7 filter running.

    Is it possible that this is a specific problem of the new 3.0 version?

    Thanks for any ideas

    maccowley

    #53170

    DrmCa
    Participant

    Quality of your voip calls will only benefit from router’s QOS if your ISP supports QOS too. Been there done that.

    Ping to voip proxy has times more impact than your router’s QOS alone.

    #53171

    maccowley
    Member

    This doesn’t help me to solve my problem.

    First I have to control the bandwidth on our Internet line and then I can think of QOS of the provider.

    #53172

    imported_fulvio
    Participant

    Could you try to classify http traffic by using Layer 7 filter?
    I need to understand if your problem is due to the Kernel L7 module or just to signature bugs.

    Regards
    Fulvio

    #53173

    DrmCa
    Participant

    @maccowley wrote:

    This doesn’t help me to solve my problem.

    First I have to control the bandwidth on our Internet line and then I can think of QOS of the provider.

    A little while ago I had the same feeling. But then I realized, that I can QoS SIP/RTP for all I wanted, but provider would just ignore my attempts and transfer all packets in the order received, thus negating any attempts at QoS on my side.

    What are you trying to achieve? Prioritizing Voip traffic over HTTP?
    This is what’s going to happen: someone on your LAN is downloading a file while you are trying to talk over your Voip phone. Your provider does not know about that. You configured ZS to prioritize Voip traffic, but provider is still flooding you with HTTP packets of that download. What do you want the router to do?

    #53174

    maccowley
    Member

    QOS and traffic shaping works very well when using e.g. ip filters. This enhances the quality of VOIP.

    If the router or in my case the bridge doesn’t acknowledge the http packets, your provider can’t flood your line. This is the basic method of handshake.

    #53175

    DrmCa
    Participant

    🙂 There is no ACK for every packet.

    #53176

    maccowley
    Member

    None of the L7 filter works, even not http.
    Filter with IP addresses or port numbers work without any problems.

    I read in the forum that there was a problem with 2.0 RC3 and L7 level filter, too. Maybe this is an older bug?

    #53177

    Saszka
    Member

    Yes, L7 filter on Zeroshell 3.0 still not work property in router mode.

    QoS when using ip filter or packet work, but when we choose L7 filter (http, voip etc), QoS don’t see packets.

    #53178

    imported_fulvio
    Participant

    It seems that in bridge mode L7 filters work correctly.
    I have not tried routed mode.
    Regards
    Fulvio

    #53179

    maccowley
    Member

    I started setting up the bridge from scratch and added a level 7 for http only. Not a single bit is assigned to the http class. Everything is default.

    I can’t agree that the level 7 filters in bridge mode work correctly.

    I will give version 2.0RC3 a try.

    #53180

    maccowley
    Member

    Same problem with 2.0.RC3: Level 7 filters don’t work. I have tried both: router and bridge mode. Other filters work flawless.

    #53181

    lannet2k
    Member

    Also looking in the traffic statistic the filtering is alway 0 all traffic goes to default.

    #53182

    timoguic
    Member

    I also tried to get the L7 filters to work on my setup in routed mode, but the statistics show the class does not fill. It actually works fine when using IP / ports combination.

    I did not try it in bridged mode yet. It would be nice to have this fixed if it is a bug. I tried to look into it, no luck 🙂

    #53183

    sanctusmob
    Member

    Still nothing?

Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.