lan, wlan, wan1 and wan2

Home Page Forums Network Management ZeroShell lan, wlan, wan1 and wan2

This topic contains 2 replies, has 0 voices, and was last updated by  woodym 10 years, 6 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #41381

    woodym
    Member

    hello,
    i try to create a router for lan,wlan,wan (2). i found zeroshell an try it.
    first i have one net vor lan (192.168.1.0/24). the wlan must have the same net as lan. on second step i try wan2.
    i try to set the ip of wlan within the lan-subnet. that dosn’t work (error.. the same subnet).
    i try to set the wlan on other network (192.168.2.0/24). this works with wan, but no access to lan. lan have no access to wlan.
    i try bonding wlan and lan and bridged wlan and lan. if i do this the wlan have acces to lan and wan. the lan have access to wlan an wan but it’s not posible to login as ssh. about 1 hour it’s posible to access over https but after that time the the box ‘hangs’. no wlan, no lan. the box is 1 alix-board with 3 nic and 1 atheros minipci.

    is it posible to use only one ip for wlan and one ip for lan for gateway (it can be the same) within the same subnet and having access to ssh and https to zeroshell?

    is it posible the config are working but the binding for ssh and https are break for bridged interface’s (the wlan dosn’t work to)?

    have any a working config for me?

    bye woodym

    #47335

    imported_fulvio
    Participant

    I suppose your LAN is connected to the ethernet interface ETH00 and your WiFi LAN to the ETH01. I do not know if your zeroshell box is also a wireless access point or just you connect the ETH01 to external AP, but it is same.
    If the wired LAN and the wireless LAN must share the same subnet and hence the same default gateway and the same dhcp server, you need to create the bridge BRIDGE00(ETH00,ETH01) and assign it only one IP included in the subnet. This IP will be the default gateway for wi-fi and wired clients.
    You will be able to use this IP to administer zeroshell by using either ssh or the web interface. The WAN interface (I do not know if you use a PPPoE, UMTS/HSDPA or ethernet interface, but is the same) must be included in the NAT interface list from [Router][NAT] so all the source IP of the outgoing packets will be masqueraded with the public IP of the router.

    Regards
    Fulvio

    #47336

    woodym
    Member

    hello,
    thank you for fast answer..
    that is what i do. but the ssh and (after about one hour the https) of zeroshell dosn’t work. the config is:

    ETH00 (LAN 192.168.1.0/24 192.168.1.1)
    ETH01 (WAN1 for future)
    ETH02 (WAN with ppoe -> ppp0)
    ETH03 (WLAN Atheros chipset on minipci)

    i have create BRIDGE00 with ETH00 and ETH03. at this moment only ppp0 in NAT included. the access to WAN works. but the access to zeroshell ssh and (after one hour) to webinterface dosn’t. the login to wlan works for one hour. i use ‘Release 1.0.beta11’.

    i see a error after creation of bridge ‘ERROR: BRIDGE00 not created: ‘ but the bridge is listet on network without errors:

    BRIDGE00 (ETH00,ETH03) Forwarding State (STP: Disabled)
    wlan – lan UP
    192.168.1.1 255.255.255.0

    ETH00 100Mb/s Full Duplex
    VIA Technologies, Inc. VT6105M [Rhine-III] (rev 96) UP
    This device is member of BRIDGE00 (ETH00,ETH03) Path Cost: 19
    Dynamic IP: 0.0.0.0 MAC: 000DB9152224

    ETH03 AP:002127C1DB53 Freq: Current Frequency=2.462 GHz (Channel 11) Tx-Power:16dBm (39mW)
    WiFi – [SSID:testssid] [Mode:ap] [Security:wpa-psk] [Hidden:no] UP
    This device is member of BRIDGE00 (ETH00,ETH03) Path Cost: 100
    Dynamic IP: 0.0.0.0 MAC: xxxxxxxxxxxxx

    i look to setup – ssh … the allowed ip is 192.168.1.0/24 from ETH00. if i insert 192.168.1.0/24 BRIDGE00 the login works. now i wait few hours to see if it’s working.

    bye woodym

    #47337

    woodym
    Member

    now it’s work stable , thank you.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.