Issues with internet failover

Home Page Forums Network Management ZeroShell Issues with internet failover

This topic contains 4 replies, has 0 voices, and was last updated by  Montikore 1 year, 1 month ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #44869

    Montikore
    Participant

    Hi,

    Since 2 weeks, i’m experiencing lot of troubles with my VoIP services : it sticks on the failover device (4G modem), even when there is no problem with the main connection. All other connections are using the main link, but the VoIP service is not… And is not working as well.
    I’m using this configuration since month’s without problems, and updated to 3.8.0 one month ago. Is there any issue with internet failover on this version? Something changed? Is there any differences between x86 and x64 versions?

    Thanks

    #54547

    DrmCa
    Participant

    Try a previous version, and see. I did not have issues with 3.5.0 while I still used load balancing configuration.

    #54548

    virgiox
    Member

    We use load balancing with balancing rules routing SIP traffic to a preferred gateway. When it fails a new one is chosen, but while UDP NAT sessions are alive on the new gateway, it is used regardless the status of the preferred one.

    The only way to switch your gateway back is to let NAT sessions expire (turn SIP user agents off) or manually disable the new gateway. I guess it does not happen with http connections because their lifespan is shorter, while UDP ones could last forever.

    #54549

    Montikore
    Participant

    @virgiox wrote:

    When it fails a new one is chosen, but while UDP NAT sessions are alive on the new gateway, it is used regardless the status of the preferred one.

    This sounds pretty logical in regard of our situation. And indeed, this issue affected only our VoIP services.
    By the way, i didn’t find how to configure/disable SIP user agents you talk about. Where can i do that?

    So i guess to solve this issue, you have to set UDP NAT session timeout to very short time… ?

    #54550

    virgiox
    Member

    @montikore wrote:

    By the way, i didn’t find how to configure/disable SIP user agents you talk about. Where can i do that?

    So i guess to solve this issue, you have to set UDP NAT session timeout to very short time… ?

    SIP user agents are the SIP devices you are using through your NAT. It could be your IP-PBX if on premises or your IP phones if your PBX is in cloud.

    Reducing UDP NAT sessions timeout to a value lower than SIP register refresh is not a good idea as by doing so incoming requests will often find a closed door. Neither is turning your PBX or phones off until their NAT sessions time out.

    I usually flush all NAT sessions: security->firewall->connection tracking->flush.

    Quick and dirty (very dirty)

    #54551

    Montikore
    Participant

    dirty things can be done once in a while 😉
    ok thank you for the information! i think i’ll have some testing to do around it

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.