Insufficient key material or header text not found found in

Home Page Forums Network Management ZeroShell Insufficient key material or header text not found found in

This topic contains 7 replies, has 0 voices, and was last updated by  otros1761@gmail.com 9 years, 8 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #42287

    Hello,

    I am trying to cosntruct a lan to lan VPN from another Company
    This , have told me the preshared key “JVh3sr5I6C” to put into my vpn configuration.
    They are using the Encryption Method IKE: AES256:SHA

    My questions are:
    – If they are giving me the preshared key , how am I acting as a server or client?
    – I have got the following error when i Save my conf:
    Insufficient key material or header text not found found in file ‘/tmp/VPN00.psk’ (10/128/256 bytes found/min/max)
    exiting

    Could anyone help me. Thanks very much

    #49902

    ppalias
    Member

    Could you post a screenshot of the configuration?

    #49903

    Firs I tried to put the preshared key in ascii, and I Have got an error about the NOn-HEx code.
    And after I put it in hexadec snd I have got the “Insufficient key material or header text not found found in” error

    Thanks and Regards

    #49904

    ppalias
    Member

    Looks like you should not leave spaces in the key.
    If you use the gen-key button next to the passphrase field you will get something like the following:

    6dc3c6b2ca6ae91e5a344061fdbbbb5bc05943b774bedf11023660bcfc95d94cbe01fc1755611ea44c3f27031ab66d1ba627262b5b158e0941bb6475dd090972ded8cf0aac13487722fbad1068c526a081f0db0969e2f4c96665e3ba78238b71c0d039450afc1a5e7e6560fb4d9565458596c8e5da654906baf01faece8786768a62a6383ba64a6d50e4e8d5c0276260183259e39433212ab9734ffbe22f64e3819ab99c1b338623747c46af6ac09997afe0416dc007e239dcd0d608f4b47627f811cd24201b586217660f7508af406753239afd773623cf6becb8b57874f4ccffa09a91f03b82569fd5f42b94a18fa659b64ee9438b60052d68573555b931ee

    I suggest you use the gen-key button to provide you a correct key.

    #49905

    Yes that’s rigth, but in the case that a preshared key is given, what should I do?

    The other side gave me the key, to put it into my side
    They gave me an ascii preshared key, I introduce it in the zeroshell and I have got the error related to the non hex characters.
    So I convert the ascii key into hex and I tried to introduce it and I have got the error “Insufficient key material or header text not found found in”

    What can i do?
    Thanks

    #49906

    ppalias
    Member

    If the ascii key they gave to you contains only letters from a to f and numbers then delete any spaces and try to insert it in the field without any conversion.

    #49907

    I am trying to introduce: JVq3rc6I5M

    and I have got:
    Non-Hex character (‘J’) found at line 2 in key file ‘/tmp/VPN00.psk’ (0/128/256 bytes found/min/max)

    Thanks,

    #49908

    ppalias
    Member

    As I said before letters in hex are A-F, J is out of this window, so it is no surprise to give you an error.
    The key you are trying to insert is too small, it is only 10bytes and Zeroshell expects at least 128bytes up to 256. I suggest you generate a key on ZS and send it to your peer.

    #49909

    OK thx

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.