HTTP PROXY going permanently down

Home Page Forums Network Management ZeroShell HTTP PROXY going permanently down

This topic contains 6 replies, has 0 voices, and was last updated by  hades 9 years, 9 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #41037

    hades
    Member

    Please I need help, HTTP Proxy is permanently going down with following error, could someone help me to fix it?

    17:51:31 === Starting HAVP Version: 0.88
    17:51:31 Running as user: havp, group: havp
    17:51:31 Use transparent proxy mode
    17:51:31 — Initializing ClamAV Library Scanner
    17:51:31 ClamAV: Using database directory: /var/register/system/ClamAV/db
    17:51:35 ClamAV: Could not load database: MD5 verification error
    17:51:35 Error initializing ClamAV Library Scanner!

    #46504

    imported_fulvio
    Participant

    Try the following command:

    rm -f /var/register/system/ClamAV/db/*

    and then restart the proxy server. In any case check that your storage device is not full.

    Regards
    Fulvio

    #46505

    hades
    Member

    Thank you very much, it helped.

    #46506

    fristle
    Member

    Hi there,

    got the same problem. Libraries end up with MD5 error.

    Partition 1 free space 77%
    Partition 2 (activated profile) free space 92% (3GB)
    RAM 256 MB on a Pentium Celeron 400 MHz machine

    rm command didn’t work out.

    1 What else could be the problem?
    2 How can AVcheck be disabled at all?

    cheers
    Tobby

    #46507

    fristle
    Member

    any idea about the error?

    cheers
    Tobby

    #46508

    yum
    Member

    Hi

    2 How can AVcheck be disabled at all?

    Don’t use HAVP proxy. It’s main purpose is to make AVcheck. Don’t know if another HAVP functions (whitelist/blacklist) are important for you.

    #46509

    JC
    Member

    fristle:
    Depending on the traffic through your router there may not be enough processor/RAM to handle it. I had a 400 w/ 128 and it ran fine till i added havp white/blacklist then it got slow, more ram helped slightly but once i got my hands on a 1.7 w/ 512 it ran much better. the MD5 may also just be corrupt from the dl, or the device may have bad sectors. are you using zs 1.0.beta11?
    to turn off the AVcheck simply uncheck the “enabled” choice under http proxy.

    #46510

    fristle
    Member

    @yum
    your post makes sense. Theres no need for using a HAVP Proxy in my case. As I m using ZeroShell on my machine I decided to use the built in Proxy rather than having the hassel to setup another Proxy. Thanks for your post.

    @jc
    thanks for your post. The problem seemed to b a corrupt hdd. Fixed it, installed latest libraries by hand. Proxys running now, despite the OUTDATED error (0.94 instead 0.95.1). I m running Release 1.0.beta11b.
    The Proxy enabled/disabled dropdown box in http proxy is greyed out though.
    cheers for your help, mate.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.