[HOWTO] Failover with a costly connection (3G no flatrate)

Home Page Forums Network Management ZeroShell [HOWTO] Failover with a costly connection (3G no flatrate)

This topic contains 1 reply, has 0 voices, and was last updated by  aseques 9 years, 11 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #41816

    aseques
    Member

    There was a problem with zeroshell when using expensive failover methods (3G connection, RDSI line, etc) that had to switch to failover automatically and when recovered go back to use only the main line.
    The problem is that those interfaces where also monitored and so they where never stopped (on most rdsi routers a ping is the keepalive for the connections)

    The changes I made on the scripts check for a new flag NoCheck in the attributes of the gateway.
    If the flag is present the connection won’t be tested and zeroshell will assume that it’s active all the time.

    If you don’t add the flag nothing will change.
    I put the installer at bitbucket, following the instructions at copy_to_profile.sh should be easy to install on your system (as a bonus you’ll get mail alarms for the failover too 🙂 )

    $ hg clone http://bitbucket.org/aseques/zeroshell-documentation/

    To fulvio: It would be good to add this feature in the next release, since we cannot modify the interface, the flag has to be set by hand, and it’s not so practical as it would be.

    NOTE: Remember to enable the startup scripts from Setup -> Setup/Cron from the web interface.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.