How to turn off swap in ZS 1.0b14

Home Page Forums Network Management ZeroShell How to turn off swap in ZS 1.0b14

This topic contains 1 reply, has 0 voices, and was last updated by  knura 8 years, 2 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #42966

    knura
    Member

    Image file: ZS 1.0b14 for ALIX.
    Hardware: ALIX.2D13 (128MB memory)
    CF: 2GB

    My understanding about flash based disks, they have a “limited” number of writes and therefore not use any swap partition or file.

    On the CF, the third partition /dev/hda3 has a file called “swap-file” about 128MB in size and is used by the kernel.

    I have tried removing it but it is recreated at next boot up.

    Is there a way to disable swap?

    Thanks,
    — Arun Khan

    #51720

    knura
    Member

    @knura wrote:

    Is there a way to disable swap?

    I am new to ZS and learning about it’s administration as I am going through it’s configuration – both from WebIF and CLI (ssh and serial console).

    I figured out how to turn off swap:

    WebIF:

    SYSTEM > Starup/Cron

    1. In the Scripting Editor select “Post Bootup”
    2. Add “/etc/init.d/swap stop” (w/o the quotes)
    3. Test and Save

    HTH,
    — Arun Khan

    #51721

    atheling
    Member

    The more usual way to avoid paging is to simply have enough RAM for your needs. My little ZS box has not been restarted in 6 months and it shows zero swap space used.

    Not sure what Linux will do if it needs swap and there is none…. You might want to investigate that.

    Regarding excessive writes to flash, I’m more concerned about logging and statistics gathering than I am about swap space.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.