how to set zeroshell to use ppp0 only

Home Page Forums Network Management ZeroShell how to set zeroshell to use ppp0 only

This topic contains 9 replies, has 0 voices, and was last updated by  scegg 9 years, 1 month ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #42128

    scegg
    Participant

    Hi,

    I have a zeroshell router with 2 ppp links and net balancer enabled.

    I found that’s difficult to connect to ports of zeroshell web console and openvpn.

    How can I set the zeroshell router only use one of the ppp, not both?

    Thank you.

    #49347

    ppalias
    Member

    You have to create a netbalancer rule to distinguish which traffic will be sent from a specific connection.

    #49348

    scegg
    Participant

    @ppalias wrote:

    You have to create a netbalancer rule to distinguish which traffic will be sent from a specific connection.

    Thank you for your reply.

    You mean to create a rule: Source IP = Router Local IP ?
    Is that OK for working with Virtual Server Port Mapping function?

    Result: After I creating that rule, all computer without static rule cannot visit internet. It seems be wrong.

    #49349

    ppalias
    Member

    I was not referring to Virtual Server. On Virtual Server you have to enable the port forwarding on the WAN interface you wish to have.

    Go to Network -> Load Balancer -> Balancing Rules
    Click on ADD and on the new window set the IP-ports-whatever is your criteria for distinguishing traffic and on target gateway select the gateway you prefer.

    #49350

    scegg
    Participant

    @ppalias wrote:

    Go to Network -> Load Balancer -> Balancing Rules
    Click on ADD and on the new window set the IP-ports-whatever is your criteria for distinguishing traffic and on target gateway select the gateway you prefer.

    I added a rule:
    Source IP: RouterIP
    Source Port: 1194 (OpenVPN)
    Router: ppp0
    Sequence: 1
    And save.

    After that, I still cannot visit 1194 port from ppp0 outside. TCP no response.

    And, I added a similar rule for port 443. I cannot visit https management site of router either.

    And, after I added these rule, all computer without static netbalancer rule cannot access to internet.

    #49351

    ppalias
    Member

    This is my working configuration. You don’t need a virtual server, unless the openvpn server is on an internal server and not on ZS.

    #49352

    scegg
    Participant

    Thank you for your reply.

    It seems that your rule adjusts all TCP connection from port 1194 of all IP (computers and router included) to ppp1. How can I modify this for only router? I changed the source IP to router IP but no help.

    #49353

    ppalias
    Member

    Your OpenVPN server is on another machine or on Zeroshell?

    #49354

    scegg
    Participant

    It’s on ZeroShell.

    #49355

    ppalias
    Member

    Another thing you could do is to negate the LAN interface at the source interface, so that it will match packets with source tcp port 1194 not coming from your LAN. Happy now?

    #49356

    scegg
    Participant

    Thank you.

    I’ve tried several ways in several days.
    I have to disabled the 2nd ppp and netbalancer from router. Now I’m using the 2nd link directly on one of my server. No more confused configuration now.

    Thank you again.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.