how to redirect to local server, instead of xDSL box ?

Home Page Forums Network Management Networking how to redirect to local server, instead of xDSL box ?

This topic contains 1 reply, has 0 voices, and was last updated by  ormaa 3 years, 4 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #44422

    ormaa
    Member

    Hi,

    I installed zeroshell 3.4 x86 on one PC

    here is the config :

    eth1 of the pc is connected to ther port of xDSL device.
    eth2 of the pc is connected to a switch.
    on the switch, I have 2 mac computer.
    one is a web server.

    I own a domain name (mydomain.fr) , which redirect to the publix IP if the xDSL device.
    the public ip is something ike 90.185.12.24 (I give an example here)

    the public ip is dynamic, but for the moment it is not an issue until I reboot the xdsl device.

    the xDSL device deliver a static ip to the eth1
    the gateway of the xDSL Device is 192.168.1.1

    the system is configurer in router mode.
    eth1 has a static ip: 192.168.0.70
    eth2 has a static ip : 10.10.10.1.
    I defined the dhcp server at 10.10.10.1
    I use the dns of google : 8.8.8.8
    this part works fine : all my computer on the switch has access to internet.

    I defined 2 virtual server :
    ETH01 / ANY TCP 80 10.10.10.2:80
    ETH00 / ANY TCP 80 10.10.10.2:80

    it seems to work fine, because I can have access to my web server (on computer 10.10.10.2), from a smartphone in 4G for example.

    now, I have an issue, and need, probably, some parameter.

    if I try to acces, from a local computer : 10.10.10.3, to my web server, suing the domain name http://www.mydomain.fr, I am redirected to the xDSL admin page (accessible by 192.168.1.1)

    I read on internet, that somepeople call it nat loopback, some other says hair pinning.

    on my side, I don’t have enough knowloedge to say.

    question :
    how can I solve it ?

    thanks
    Olivier

    #53945

    ormaa
    Member

    Hi,

    it was quick :o)

    I will answer to myself.

    I followed this solution :
    https://wiki.afm.co/display/PUBL/How+to+enable+loopback+on+a+NAT+with+Zeroshell

    af first, I was thinking that it was not working.
    in reality, the computer used to do my test is connected to the xDSL box directly (to allow to have internet, even if I brak the router :o)

    so it was not using the virtual server defined to do “nat loopback”

    now, I just tested with this virtual server
    ANY / ggg.hhh.zzz.xxx TCP 80 10.10.10.2:80

    the computer connected on the router

    it works !

    Note to the developper team :
    Great job ! it is very nice !!!

    thanks
    Olivier

    #53946

    somertech
    Member

    This does not work for me. After configuring as article suggests, I still cannot resolve internal web server.
    I am no longer redirected to Zeroshell admin interface, but attempt simply times out.

    Frustrating

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.