how to install zeroshell on virtualbox

Home Page Forums Network Management ZeroShell how to install zeroshell on virtualbox

This topic contains 3 replies, has 0 voices, and was last updated by  Franck Aristide Ouedraogo 2 years, 7 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #44469

    hi , i’m serious problem to install zeroshell in virtualbox.javascript:emoticon(‘:cry:’)
    after the first installation i can’t create a profile.
    in addition when i am in the power shell i see this :” franck@root ~> ” and can’t munt my disk.
    help me please. 😥

    #53988

    reaperz
    Member

    I cannot help you with your problem, but for me getting Zeroshell lto work on virtualbox was very easy. Just downloaded the image, configured Virtualbox machine and run it. works fine!

    Make sure to use 32-bit kernel.

    #53989

    iulyb
    Member

    Hi,
    My issues were in configure virtualbox in order access and manage zeroshell (guest) from the linux host that has virtualbox.

    Download latest CD ISO zeroshell image.
    Check from your host that you can

    ping google.com
    ping 8.8.8.8

    If the above commands doesn’t work yu need to replace the google’s DNS 8.8.8.8 with ior ISP’s resolver IP.

    1) First create new linux (64) in virtualbox. Setup 1-2G of space. Name it virtual_zh.
    2) Under Virtual box File -> Preference -> Network -> Host Only Networks tab add a new network and set the IP 192.168.0.1. This should be different that your current subnet. Do not enable DHCP. On your host check the IPs. Should be somenthing like this:

    $ip addr
    11: vboxnet2: mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 0a:00:27:00:00:02 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.1/24 brd 192.168.0.255 scope global vboxnet2
    valid_lft forever preferred_lft forever
    inet6 fe80::800:27ff:fe00:2/64 scope link
    valid_lft forever preferred_lft forever

    3) Under virtual box Click on virtual_zh then settings. Under Network create 2 interfaces, first as Host Only, select the network created at point 2, then click on Advance and under promiscuous mode select Allow All. Second interface should NAT. Depending on your needs you may change or add more interfaces.
    4) Start guest and boot from CD.
    5) After starting click install and setup the IP o.n te same network that you have at point 2. ( default to 192.168.0.75 ). Attention should be done in matching the interfaces, address 192.168.0.75 should go into ETH00.
    6) Restart guest, login then press s then check IPs. You should have something like

    $ifconfig
    ETH00:00 Link encap:Ethernet HWaddr 08:00:27:34:5C:FE
    inet addr:192.168.0.75 Bcast:192.168.0.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

    At this point ETH01 is not configured, you need to enable DHCP. Press Ctr C then I on command line or go to nr 8.
    7) If everything ok you should be able to ping guest from host

    $ping 192.168.0.75.

    8) point your host browser to 192.168.0.75 and login to zeroshell guest. You might need to enable DHCP on ETH1. For this go Setup -> Network then click Dyn.IP button for ETH1. On the new window click enable then close. Make sure u get an IP. (usually like 10.0.x.x ). If all OK you should be able to ping goole’s DNS.

    $ping 8.8.8.8

    9) Go under Setup -> ssh and enable ssh access. You should be able to login to zeroshell with ssh

    $ ssh admin@192.168.0.75

    10) Ping google.com. If this works we are done. Most probable this will not work due to virtualbox limitations.. we need to fix the resolver.

    echo "nameserver 8.8.8.8" > /etc/resolv.conf

    Please note that this will not last reboot so you may want to use your browser and add this line into zeroshell’s cron/scripts section. On the web interface go under Setup then click on Script/Cron. On the new window select post boot and add the line above. Check enable then save.

    Hope this helps other people.

    #53990

    reaperz
    Member

    I use USB image both for Virtualbox (just mount the disk) or physical routers (using physdiskwrite).

    Also I use Bridged interfaces in Virtualbox, not NAT.

    #53991

    DrmCa
    Participant

    Installing was smooth for me too, I always use bridged mode for all guest NICs so accessing it was just the same as accessing any other machine on my LAN. If the OP still has the issues, I would suggest re-downloading the install image and re-installing.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.