How to configure the network cards?

Home Page Forums Network Management Networking How to configure the network cards?

This topic contains 5 replies, has 0 voices, and was last updated by  omnisys 9 years, 7 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #42002

    omnisys
    Member

    I have internet on a router and i want to put zeroshell server between the router and my company network, see below.

    router (192.168.1.1)—> ZS


    > internal network

    on ZeroShell ETH00 is the one connects to the internet router and ETH01 is the one that connects to the internel network…..

    WAN IP: 192.168.1.2 LAN IP: 192.168.0.75 (gateway for the dhcp too)

    any help?????

    #48982

    ppalias
    Member

    I would suggest to remove the internet router and let ZS do the job. If it is an adsl line set the modem to bridge mode (rfc1453) and setup ZS to PPPoE. Otherwise it is going to be a big mess with double NAT and port forward.

    #48983

    omnisys
    Member

    But i dont want to get an other modem to do the job…….

    any idea how to do the NAT?????

    #48984

    JC
    Member

    u can use the modem u already have, u simply set eth00 to b ur local network, then setup an internet connection, i am used to adsl so in my setup –> network i have eth00, eth01,ppp0 eth01 is linked to ppp0. ZS will do all your DHCP w/ minor setup, routing, firewalling.the NAT will work “out of the box” under adsl the NAT auto sets itself.

    #48985

    omnisys
    Member

    it does not make sence….

    my ADSL router is already connected to the internet……….

    the LAN output goes on the ETH01…. which somehow has to be shared in order to forward the internet to the ETH00……..

    No Dial is going to happen from the ZS

    #48986

    JC
    Member

    so if ur adsl comes in on eth00 and ur LAN is connected to eth01, set eth00 to the ip subnet that the router wants to use, set ur eth01 to ur LAN subnet, then under NAT enable it on eth00 and u should have connectivity. u may need to set a static route to the modem.
    i have a router behind my main to separate a small problem subnet and i had to static route from them to the main gateway. the gateway is 192.168.0.1, their network is 192.168.1.0 so i set
    Destination Netmask Type Metric Gateway Interface
    0.0.0.0 0.0.0.0 Net 1 192.168.0.1 Up

    hope this helps

    #48987

    7andY
    Member

    As there are visitors of many nationalities on here, can I suggest that you do not use shortened versions of English words (‘u’ and ‘ur’ etc). It will make reading a lot easier for all concerned.
    Cheers, 7&Y

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.