How to change resolv.conf?

Home Page Forums Network Management ZeroShell How to change resolv.conf?

This topic contains 5 replies, has 0 voices, and was last updated by  DrBrain 9 years, 5 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #42058

    DrBrain
    Member

    Hello,

    I need to add my local DNS on resolv.conf but the filesystem on which it resides is read-only. Can you please let me know how is it possible to do such a basic change as this one?

    #49148

    atheling
    Member

    I’m new to this too, but I think you can go to the DNS page and setup the “forwarder” DNS address to be your local DNS machine.

    You might have to create a DNS zone. (Not sure as I created a DNS zone at the same time I set up the forwarders to be the DNS servers of my choice.)

    #49149

    DrBrain
    Member

    Hello.

    I did that for server ANY but it doesn’t work 🙁 I don’t have a DNS zone though. It really can’t be that difficult… any help guys?

    #49150

    atheling
    Member

    I’m beating my head against the wall on my initial setup in a different area. When I get home and work on it some more this evening I’ll take another look at the DNS settings and see if I can figure out what the deal is.

    My case may be slightly different too as I’m running off a flash drive rather than a CD so I think I might be able to directly edit some areas. I haven’t tried that yet, just using the UI to set things then using a Bash shell to examine the results to see what I’m actually getting.

    #49151

    atheling
    Member

    I took a little time to see how the DNS is configured. Looks like resolv.conf always points to localhost. So setting the forwarders for the DNS server running on Zeroshell is probably the official way to do things.

    It looks like the forwarders list can be independent of any zones (“ALL”) and that ought to work.

    When you use the “dig” command on your Linux/Unix client machine what does it show?

    #49152

    ppalias
    Member

    It has to be done in the DNS forwarders page with the “ANY” keyword. Then it works fine. Don’t forget to save and make sure the DNS you add allows you to query recursively.
    If problem still exists, as atheling mentioned issue the dig command on a shell and paste the output here.

    #49153

    DrBrain
    Member

    Thanks for the answers. Actually, what was missing in my configuration was the ‘Default Gateway’ (my ADSL modem). After setting it up through the command-line menu, DNS resolution worked fine without having to set anything in the DNS forwarders.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.