help setting up Qos in VMware ESX lab

Home Page Forums Network Management ZeroShell help setting up Qos in VMware ESX lab

This topic contains 3 replies, has 0 voices, and was last updated by  fishfilet 11 years ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #41156

    fishfilet
    Member

    I want to use Zeroshell to do Qos and traffic shaping. I use a Virtual environment using VMware. Here is how I have things set up.

    [Internet] > [T1 router] > [physical switch] > [ESX host] > [vSwitch1] > [Zeroshell Virtual machine NIC 1 (Eth00) ] | [Zeroshell Virtual machine NIC 2 (Eth01) ]> [vSwithc2] > [virtual machine]

    My T1 line comes into a physical switch.

    My ESX host also goes into that switch. This allows virtual machines running on that host to connect to the Internet.

    Zeroshell is running on a virtual machine with two NICs.

    One is connected to a virtual switch that has access to the physical switch and thus has access to the Internet. I can ping Internet sites such as google from within the Zeroshell web GUI so I know I am connecting to the Internet from the Zeroshell virtual machine.

    The other NIC inside the Zeroshell virtual machine is connected to another virtual switch that is internal to the ESX host. If I am doing this right this should allow any other virtual machines on that switch to go through Zeroshell on the second NIC and then to the Internet on the first NIC.

    In Zeroshell I have bridged the two NICs which are Eth00 and Eth01.

    I have also enabled Qos on both NICs.

    After all of this I am unable to reach the Internet from virtual machines running on the internal switch. I cannot ping out. I cannot ping the Zeroshell virtual machine either even though I am pinging from a virtual machine that is on the same virtual switch.

    I am not sure if I should set the default gateway on the machines that should go through zeroshell to the zeroshell address or if it should stay how it is.

    The virtual machines do get DHCP settings properly so I know I do have connectivity like this

    [Internet] > [T1 router] > [physical switch] > [ESX host] > [vSwitch1] > [Zeroshell Virtual machine NIC 1 (Eth00) ] | [Zeroshell Virtual machine NIC 2 (Eth01) ]> [vSwithc2] > [virtual machine]

    But for some reason I cannot get from my virtual machines out to the Internet.

    Does anyone have any ideas? Maybe I just have this setup wrong all together in which case I can start over if someone can tell me how.

    #46834

    fishfilet
    Member

    I dont know if it helps but it looks like this is a similar situation that was solved in a round about way. I would like to know if there are any other suggestions before i try this.

    http://www.zeroshell.net/eng/forum/viewtopic.php?t=709&highlight=bridge

    #46835

    fishfilet
    Member

    OK I have tried setting up zeroshell as mentioned in the above post but I am still having a problem.

    Zeroshell has two NICs, Eth00 and Eth01.

    Eth00 is 10.0.0.10

    Eth01 is 192.168.0.10

    I have machines on the 192.168.0.0 network as well as machines and the internet router which are on the 10.0.0.0 network.

    How do I route these networks together? I cannot get from one network to the other. I thought that zeroshell was a router and would do this automatically but there is something i must be missing.

    #46836

    imported_fulvio
    Participant

    On my opinion if you use a virtual machine to run Zeroshell the bridge forwarding does not work because Zeroshell is unable to put the interfaces in promiscuous mode in the virtual environment. Probably VMWARE do not allow this for security reason. The promiscuous mode is needed because the bridge have to process every ethernet packets. For a workaround try to read the document http://www.vmware.com/support/esx21/doc/esx21admin_virtualadapter.html

    In any case, Zeroshell is automatically set to act as router. Of course, you must correctly set your clients and the Internet access router to use the Zeroshell router.

    Regards
    Fulvio

    #46837

    imported_fulvio
    Participant

    Look at the post http://www.zeroshell.net/eng/forum/viewtopic.php?t=832 in which the same problem appears and it has been solved by allowing the promiscuous mode of the bridged interfaces.

    Regards
    Fulvio

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.