Help: QoS managing crash at entry nº 60

Home Page Forums Network Management ZeroShell Help: QoS managing crash at entry nº 60

This topic contains 9 replies, has 0 voices, and was last updated by  ingeniado 11 years, 6 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #40743

    ingeniado
    Member

    Hello,

    I’m configuring bandwith per IP. (70 hosts)
    I’ve created chains and assigned them to interfaces.
    I was creating the rules in the classifier and, when I was at entry number 60 (host nº 30, because 2 rules per IP: upstream & downstream), an “ERROR” message is shown under “QoS Rules” title. ❗
    I can’t see the rules, neither ADD.
    I did reboot the system and.. the problem persists.

    (I use 1.0.beta5 version).

    Thanks.
    Michael

    #45778

    imported_fulvio
    Participant

    I will check and try to fix the bug in the next release.

    Regards
    Fulvio

    #45779

    ingeniado
    Member

    OK.
    I’ll waiting for next release.

    Thanks very much.

    regards
    Michael

    #45780

    imported_fulvio
    Participant

    This bug has been fixed in the release 1.0.beta7.

    Regards
    Fulvio

    #45781

    ingeniado
    Member

    Hello,

    thanks for the new release, Fulvio.
    Now, the classifier page doesn’t crash with 60 entries, but….
    now a strange behaviour happens: 60th entry is duplicated, the second 60 entry lost the Qos class assignment and I can’t delete rear entries (61, 62..), because when I save the changes, these ones appear again 😕

    any suggestion?

    thanks.
    Michael

    #45782

    imported_fulvio
    Participant

    Could you try with a new DB?

    #45783

    ingeniado
    Member

    @fulvio wrote:

    Could you try with a new DB?

    Ok.
    I’ll try, but it will take to me a long time.
    I’ll post the result.

    Thanks
    Michael

    #45784

    ajl37
    Member

    Hi,
    I appear to have gotton around this problem.
    I stopped QoS on my two cards (bridged) disabled the QoS rules.
    Deleted them one at a time (which took a while) then saved (after deleting all 63 rules), re-enabled and added QoS back on the adapters. I now just need to add my rules back in, keeping it under 60 🙂

    I am currently using 1.0beta6, upgrading to beta7 tomorrow.

    Thanks
    Andrew

    #45785

    ingeniado
    Member

    @ajl37 wrote:

    … I now just need to add my rules back in, keeping it under 60 🙂

    Hello,

    It is not entirely clear to me whether you have lost your rules or not…
    Do you have kept 1-60 rules?

    On the other hand, I think the big problem is that the web interface to manage the classifier is not suitable for a large number of rules/classes (>60). Is hard to support.
    I think would be better an interface to manage rules in a group.

    Thanks.
    Michael

    #45786

    ajl37
    Member

    When I originally started deleting rules 61 – 63, I saw the same results as you, rule 60 duplicated itself to 61-63. By deleting them all and then saving I managed to clear the entire QoS rules list. I then entered my 60 most important.

    Its very true that the interface does not allow for easy creation of a large number of rules. It is certainly something I would like to see improved at some point, as I am currently using it to manage about 1000 clients (works very well).

    Andrew

    #45787

    ingeniado
    Member

    @ajl37 wrote:

    It is certainly something I would like to see improved at some point, as I am currently using it to manage about 1000 clients (works very well).

    If I’m not mistaken, If you want to manage bandwidth for 1000 clients (1000 IPs ?) you have to:
    – Creating 1000×2 (upload, download) classes
    – Assign 1000 classes to interface A, 1000 to interface B
    – Configure 1000×2 rules in the classifier

    Each “add action” takes one web page reload: 4000 web pages reload to get it.
    At the moment, definititely Qos rules manager is not suitable for large number os rules. 😕

    apart from that, Zeroshell is fantastic! 😉

    regards
    Michael

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.