Help needed sharing UMTS 3G to home network through ETH0

Home Page Forums Network Management ZeroShell Help needed sharing UMTS 3G to home network through ETH0

This topic contains 2 replies, has 0 voices, and was last updated by  mitchbw 7 years, 6 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #43158

    mitchbw
    Member

    Hi,

    I need to connect multiple computers to the internet through one computer using a UMTS modem (USB 3g dongle on three.co.uk).

    I have followed the instructions on the following link and still had problems:
    http://www.zeroshell.net/eng/UMTS-HSDPA-Mobile-Router/


    Namely: http://www.zeroshell.net/eng/hw/– (so the forma might need updating 😉 )

    The Problem

      I have added the USB modem to the list of networks. It has connected and the auto-update page updates with dates from September 2011. [PPP0 on USB0]
      (I notice in the log file that it says it is defulting to ip 10.64.64.64)

      I have chosen “yes” to the boxes suggested (connect automatically and default route)

      My other computer ( 192.168.0.5 ) is connected to ETH00 (ZSbox of ip 192.168.0.75 )

    [anyone know where im going wrong?]

    I have also trolled through the forum and not found much to help me.

    Thanks in Advance

    #52001

    Plagued
    Member

    If it’s connecting and updating the text then that’s the hard bit done 😉
    Have you set the gateway in ZS to 192.168.0.75 and made sure that your client is using this as it’s GW and has the correct DNS.
    I didn’t have any issues getting a three dongle running (other than needing to add the dongle settings to the config file. Just gave the zeroshell box an ip, set this as the gateway, set the dhcp up and then added the ppp0 device. In the logs I’m sure it assigns 10.64.64.64 but states it won’t replace the existing gateway.

    #52002

    mitchbw
    Member

    And just to clarify, what should the client DNS be set to, (192.168.0.75) ?

    #52003

    Plagued
    Member

    you can either set DNS to run through zeroshell, or set it to google/openDNS
    8.8.8.8 is google
    208.67.222.222 is openDNS

    Might be worth having a quick read up on basic networking, like NAT, Gateways, Subnets, DNS and so on as this will make what zeroshell is doing a lot easier to understand and help you troubleshoot.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.