Help ! – captive portal not working !

Home Page Forums Network Management ZeroShell Help ! – captive portal not working !

This topic contains 6 replies, has 0 voices, and was last updated by  neddyguy 11 years, 9 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #40588

    neddyguy
    Member

    Sorry if ithis has been discussed before , but I can’t seem to get the portal to function ?! isn’t suppose to “pop up” when IE explorer is opened?!

    I can only get it to work when i type the ETH00 ip address for the web-gui “192.168.0.75” and then I get the portal page , and then off course takes me to the admin/pass word page.

    I have searched this forum and read the excellent tutorial and followed it step by step. still no luck.

    here is my set up-pretty much standard : (from outside in …)

    internet cloud >> router (192.168.1.254/24) >> on eth01 (192.168.1.1/24) >> ZEROSHELL BOX >> eth00 (192.168.0.75/24) >>

    (( INTERNET ))
    |
    ROUTER
    |
    ZEROSHELL
    |


    | |
    (1) (2)

    (1) web server (windows box with static ip 192.168.0.100) +
    (2) a client (192.168.0.25 DHCP) connected through a hub.

    I’m also having trouble pointing to the server’s home page , I wanted to have all clients to get the server home page displayed or at least the captive portal and then the home page automatically …

    Any help is greatly appreciated.

    Thank you all …

    #45256

    neddyguy
    Member

    27 views .. and no comment ?!

    #45257

    imported_fulvio
    Participant

    Are you sure that the DNS is working?
    Try to type an external IP address in your browser (http://x.y.z.t) and tell us if it works.
    If you disable the captive portal by unchecking the flag in the [Captive Portal]->[Gateway] section, are you able to reach Internet from your clients?

    #45258

    Trantole
    Member

    I have the same and if I disable the captive portal all my clients can reach Internet without difficult but as soon as activate the portal it doesn’t work. The connction is effectively redirected towards the portal but next identification I go to the zeroshell page. There is a problem with routing the packets are not routed by Zeroshell.

    Thanks for your help

    #45259

    hackeng
    Member

    Wanted to share a same type exper.

    i had a external dns on my dhcp server config for backup.
    well two things work to fix this setup firewall access for dns without authentication or
    use only internal ip’s ie eth00 for dns.
    this made it work very quickly.

    wish you much well

    #45260

    webwarrior
    Member

    Is this suposed to work out of the box, or de i have to configure everything first, before it will start working.

    where is the tutorial everybody talks about?

    I am stuck.

    When I cannect my pc to the eth0 port of the zeroshell box, then I can log on. Then I am also not able to test connection to internet, as internet is supposed to be coeencted to etho, right? Or is it the other way around?

    HELP!

    #45261

    webwarrior
    Member

    @webwarrior wrote:

    Is this suposed to work out of the box, or de i have to configure everything first, before it will start working.

    where is the tutorial everybody talks about?

    I am stuck.

    When I cannect my pc to the eth0 port of the zeroshell box, then I can log on. Then I am also not able to test connection to internet, as internet is supposed to be coeencted to etho, right? Or is it the other way around?

    HELP!

    I got to page 11 of manual zeroshellEN.pdf, to activate the Captive Portal and tick the GW tickbox, then hit save button, when I lost connection, and now I cannot get back into it.

    Redirect when opening browser does not work either.

    Do I need to restart all over again?

    #45262

    webwarrior
    Member

    Note sure what I did wrong first time.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.