Hard-Drive installation

Home Page Forums Network Management ZeroShell Hard-Drive installation

This topic contains 6 replies, has 0 voices, and was last updated by  houkouonchi 8 years, 7 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #42437

    houkouonchi
    Member

    Anyone know of a good howto or information to get booting from a hard-drive?

    No I don’t mean the gzip -d file.gz > /dev/sdX

    The above method still acts a lot like a cd-rom except your booting the image from the hard-drive. The problem is a lot of directories are still read-only which is what I need to avoid. To get systems onboard ethernet drivers working I had to recompile a newer version of the e1000e network driver but there is no way to replace the original as that part of the image is read-only. I need to install it onto a disk where the entire system will have full read-write access (as it should being installed on an HD).

    #50425

    ppalias
    Member
    /Database

    directory is mounted RW. You may store there everything you want and then use preboot or postboot scripts to copy them after a reboot.

    #50426

    houkouonchi
    Member

    @ppalias wrote:

    /Database

    directory is mounted RW. You may store there everything you want and then use preboot or postboot scripts to copy them after a reboot.

    The problem is that the weird device names that zeroshell uses doesn’t work very well when I have to rmmod and then insmod the ethernet drivers. I think I got enough of a hint from:

    http://www.zeroshell.net/eng/forum/viewtopic.php?t=210

    to do what I want. At this point I am getting a kernel panic at boot (VFS can’t find root) but I believe this can easily be solved by copying the ahci and ata_piix modules (my chipset should use one of those) to the initrd.gz image file.

    #50427

    houkouonchi
    Member

    So the initrd was giving me problems so I compiled a new (2.6.30). Its booting and detects my NICs but they are eth0,eth1,eth2,eth3, etc… instead of ETH00, ETH01, ETH02, ETH03.

    Do you know how they get the ETHXX names? Is it a modification to the kernel source or does something call ifrename?

    #50428

    houkouonchi
    Member

    I created an /etc/iftab but even after renaming the interfaces and making entries in /var/register zeroshell was saying ‘hardware removed’ on the network configuration page.

    I think I tracked down the issue to sysfs not being mounted. After I edited the hardware detection script which runs a for loop to load modules and after that everything appears to be working as expected from the web-interface. Also interesting enough the dev order is the same of what my iftab was even though I removed the ifrename command in the hardware detection script. I will be testing it out a bit more today.

    The only issue left I have (that I know of) is that when I connect to SSH the text is all mesed up and I get an error about the terminal. This is also preventing me from logging in via SSH. I get the same type of output even when doing ssh localhost from the zeroshell box itself. Here is what it looks like:

    Anyone have any ideas what could cause this?

    #50429

    ppalias
    Member

    Terminal emulation VT100?

    #50430

    houkouonchi
    Member

    @ppalias wrote:

    Terminal emulation VT100?

    This was another problem with mounts. Aparrantly I needed to mount /dev/pts which fixed the issue now my machine is working properly.

    I also edited the /etc/passwd to not use the zeroshell front end script and added a command for that instead (for easyness to remember). Not being able to scp anything to the machine made things quite annoying. Now everything appears to be working correctly:

    root@zeroshell root> uname -a
    Linux zeroshell.example.com 2.6.30 #2 SMP Fri Jun 11 18:49:33 PDT 2010 i686 GenuineIntel unknown GNU/Linux
    root@zeroshell root> df -h
    Filesystem Size Used Avail Use% Mounted on
    rootfs 30G 1.5G 27G 6% /
    /dev/root 30G 1.5G 27G 6% /
    shm 1.5G 0 1.5G 0% /dev/shm
    root@zeroshell root>

    I am thinking about going to a 64-bit kernel though (mainly so byte counts and stuff dont reset @ 4 GB) and proper atom CPU support (maybe I was just blind but I didn’t see atom listed as an option when compiling the kernel)).

    #50431

    ngwasuma
    Member
Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.