Hard Drive extract = unknown partition

Home Page Forums Network Management ZeroShell Hard Drive extract = unknown partition

This topic contains 3 replies, has 0 voices, and was last updated by  thistleknot 9 years ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #42445

    thistleknot
    Member

    Everytime I try to extract to a HD using either the gunzip command or dd

    gunzip
    gunzip –c zeroshell.img.gz > /dev/hda1

    dd
    dd if=name.img of=/dev/sda1

    I get an unknown partition as the result.

    Any ideas? I’ve tried some alternate forms of installation, namely
    http://www.zeroshell.net/eng/forum/viewtopic.php?t=210

    but I only got it up to probing for cd media.

    #50457

    JC
    Member

    I don’t know about installing the image to the HDD, but a question arises. Is the hd formatted in an ext3/reiserfs/etc… or is it fat/ntfs. if it is fat/ntfs i would suggest u format the drive or at least a partition on the drive using ext3, if that fails, sadly, u will need to wait for someone who has done this before. i simply run the image off the cd and using pre/post boot script put my changes there.

    #50458

    ppalias
    Member

    Your command is wrong
    Use

    dd if=name.img of=/dev/sda

    instead.

    #50459

    thistleknot
    Member

    PPalia

    that’s why. Your saying I can’t extract it to a partition. Because that’s what I’ve been trying to do (and to JC, I have tried formatting the partition and not formatting it).

    The reason being is because I want to dual boot the OS. What I’m trying to do in the long run is setup an ubuntu router vs zeroshell (using webmin), but that’s another story, so I was trying to setup a first partition to hold zeroshell that I could boot to until I complete it. I love Zeroshell, I just wanted to do more with my 3.0 Ghz PC than routing.

    #50460

    ppalias
    Member

    If you want to use them both try virtualization. Having ZS in a different partition is pointless if you want my opinion. Install Virtual Box and create a new virtual server that will run ZS.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.