GCC issue

Home Page Forums Network Management ZeroShell GCC issue

This topic contains 0 replies, has 0 voices, and was last updated by  Plop 8 years, 2 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #42870

    Plop
    Member

    Hi all,

    I followed the guide from this post

    http://www.zeroshell.net/eng/forum/viewtopic.php?t=2813

    However at the end of section 5 – gcc -v still showing

    Reading specs from /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/specs
    Configured with: ../gcc-3.3.1/configure –prefix=/usr –enable-shared –enable-threads=posix –enable-__cxa_atexit –enable-clocale=gnu –enable-languages=c,c++
    Thread model: posix
    gcc version 3.3.1

    I can see updated(4.5.2) files in /usr/lib/gcc, but I don’t know how to make gcc use them.

    Any help is welcome.

    #51608

    Plop
    Member

    Ok, I’m banging my head in my desk now.

    If i go to /DB/hdb/opt/gcc4.3.2/bin and start

    root@zeroshell bin> ./gcc -v
    Using built-in specs.
    Target: i686-pc-linux-gnu
    Configured with: ../configure –prefix=/opt/gcc4.3.2 –enable-clocale=gnu –enable-shared –enable-__cxa_atexit –enable-languages=c,c++ –disable-libstdcxx-pch
    Thread model: posix
    gcc version 4.3.2 (GCC)

    I am receiving the wanted gcc version, so is this just a matter of symlink or PATH or I am just stupid?

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.