FTP client cannot connect to remote FTP server

Home Page Forums Network Management Signal a BUG FTP client cannot connect to remote FTP server

This topic contains 3 replies, has 0 voices, and was last updated by  samiux 10 years, 4 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #41406

    samiux
    Member

    I am using ZeroShell 1.0 beta11b. I have 3 network interfaces, they are ETH00, ETH01 and ETH02 (wireless). They are working fine upon fresh install. The FTP client works fine at the fresh install copy.

    After enabled WPA2-Enterprise and OpenVPN, the FTP client does not connect to the remote FTP server. The error message is “Connect timeout”. The FTP client is not running on wifi connection. However, The WPA2-Enterprise and OpenVPN are working fine.

    Meanwhile, the FTP client at the remote PC that running FTP client cannot login to the remote FTP server via OpenVPN. The error message is “Password incorrect”. By the way, the FTP client is also not running on wifi connection.

    I don’t know if it is the problem caused by OpenVPN or WPA2-Enterprise.

    Any idea?

    Samiux

    #47424

    imported_fulvio
    Participant

    Have you changed the NAT configuration? Try FTP in passive mode.

    Regards
    Fulvio

    #47425

    samiux
    Member

    I did not change the default NAT setting. The ETH01 is to be NAT.

    After discovering the problem, I had disabled the OpenVPN and/or WPA2-Enterprise interfaces but the problem still remained.

    Samiux

    #47426

    samiux
    Member

    I restore the fresh install database and setting the WPA2-Enterprise as well as OpenVPN again. The FTP client can connect to remote FTP server.

    The only thing that I did not copy is not adding a route from subnet of ETH02 to default gateway.

    Does it cause problem?

    Samiux

    UPDATE :
    I enabled the RIPv2 for all interfaces (checked all boxes and issued a password). Then, the FTP client cannot connect to remote FTP server with the error message of “Connect timeout”.

    Any idea?

    Samiux

    #47427

    samiux
    Member

    Please don’t waste your time to investigate the problem. My problem is fixed.

    I mis-configured my FTP server at Virtual Server section as well as the firewall blocked the connection.

    Sorry for bothering you.

    Samiux

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.