Forcing WPA2 Enterprise Operation

Home Page Forums Network Management ZeroShell Forcing WPA2 Enterprise Operation

This topic contains 3 replies, has 0 voices, and was last updated by  lynden 9 years, 5 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #41239

    lynden
    Member

    Hi.

    I’m trying to configure zeroshell to operate in WPA2 Enterprsie mode exclusively ie wpa=2 and wpa_pairwise=CCMP.

    From ps -ef i can see that hostapd is spawned with a configuration file in /tmp/wifi-ETH02.conf.

    I can also see that the file /root/kerbynet.cgi/template/hostapd-config/wpa-eap.conf is used as the basis of the configuration file in the /tmp directory (when I configure WPA-EAP).

    How can I make permanent changes to force WPA2 Enterprise operation. Where is hostapd spawned and which script generates the hostapd configuration file in the /tmp directory? How can I make changes to a RO partition to edit the hostapd configuration file directly?

    #47030

    imported_fulvio
    Participant

    Put the modified version of the file /root/kerbynet.cgi/template/hostapd-config/wpa-eap.conf in the /Database directory.
    Go in the form [Setup][Startup/Cron] and select the [Pre Boot] script. In the editor put the line

    cp /Database/wpa-eap.conf /root/kerbynet.cgi/template/

    Enable the Pre Boot script.

    Regards
    Fulvio

    #47031

    stevem
    Member

    Hello,

    I want to do exactly what lynden describes above, in 1.0.Beta12, but fulvio’s solution does not work. I followed the steps Fulvio describes exactly, but the changes do not take effect. /tmp/wifi-ETH04.conf still shows wpa=1 and wpa_pairwise=TKIP CCMP (the default values).

    Any yes, the pre-boot script is enabled and executes without errors at bootup.

    Any ideas?

    Thanks,

    Steve

    #47032

    ppalias
    Member

    Fulvio’s command is not correct, he missed a directory. The correct command is:

    cp /Database/wpa-eap.conf /root/kerbynet.cgi/template/hostapd-config/wpa-eap.conf
    #47033

    stevem
    Member

    @ppalias wrote:

    Fulvio’s command is not correct, he missed a directory. The correct command is:

    cp /Database/wpa-eap.conf /root/kerbynet.cgi/template/hostapd-config/wpa-eap.conf

    Thanks, ppalias! Your solution worked.

    Regards,

    Steve

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.