[fixed] Slow failover within Bond using Fault Tolerance only

Home Page Forums Network Management ZeroShell [fixed] Slow failover within Bond using Fault Tolerance only

This topic contains 1 reply, has 0 voices, and was last updated by  icyderguru 5 years, 10 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #43835

    icyderguru
    Member

    Hi,

    so i set up two openvpn Tunnels and bonded them together. My goal was to achieve a quick failover in case the Primary connection goes down. However it takes about a minute or so to actually switch from A to B.

    Does anybody know why it takes so long?

    A: LTE, VPN00, Primary
    B: 3G, VPN01, Secondary



    #53150

    icyderguru
    Member

    There seems to be a bug when “ICMP failover checking” is enabled.

    However without ICMP failover checking it is pretty much unusable. 🙁

    Does somebody know where to change the MII Polling Interval in Zeroshell?
    found it: /root/kerbynet.cgi/scripts/mkbonddev
    Or not, it does not change after saving it and restarting the bond.
    fixed: [you have to recreate the Bond]

    I am on 2.0 RC3, does somebody know if the bug got fixed in 3.0?

    #53151

    icyderguru
    Member

    On the server the mii status stays up, on the client it is down.

    So that is why it cannot work. Did anybody fix this problem?

    It turns out the virtio nic driver was causing problems.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.