eap Proxy

Home Page Forums Network Management ZeroShell eap Proxy

This topic contains 4 replies, has 0 voices, and was last updated by  gregoryfl 11 years, 6 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #40887

    gregoryfl
    Member

    Good morning,

    I am trying to proxy a RADIUS connection from a wireless
    access point to an IAS server running windows 2003. We
    have loaded Safeword, from Secure Computing, onto the
    Windows 2003 server. That process has introduced a .dll
    that will not allow eap authentication via RADIUS. I
    have been trying to strip the eap from the proxied
    request. Whenever I restart the RADIUS services on the
    Zeroshell server, the eap.conf is re-written.

    Any help you might be able to provide would be greatly
    appreciated.

    Thank you in advance,

    #46125

    rochajoel
    Member

    Zeroshell has a boot script, i believe it’s called rc.local i think, it is editable with the web interface… you can try to change it…

    #46126

    gregoryfl
    Member

    The rc.local script is one that can be used to execute my scripts. It is run after all other system scripts.

    I am specifically looking for the system script that overwrites the changes I have made manually in the eap.conf file.

    Thanks

    #46127

    rochajoel
    Member

    why don’t you copy the eap.conf file that you desire to some safe directory, and add a line on rc.local so that in the end of booting zeroshell he would copy your eap.conf configuration over the predefined one.

    #46128

    imported_fulvio
    Participant

    Try with the following workaround:

    1) cp /root/kerbynet.cgi/template.cfg/eap.conf /Database
    2) Edit the file /Database/eap.conf
    3) From the web interface section [Setup]->[Startup] enable the execution of the file /etc/rc.local and put in this file the line:
    cp /Database/eap.conf /root/kerbynet.cgi/template.cfg
    4) Reboot the system

    Regards
    Fulvio

    #46129

    gregoryfl
    Member

    I have modified the following file:

    /root/kerbynet.cgi/template.cfg/eap.conf

    Now whenever I restart the RADIUS server my changes are enforced.

    Thanks for the help.

    Any direction on removing EAP from the proxied requests? I want only MSCHAPv2 auth requests sent to my remote RADIUS server

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.