e1000e problem with 100mb line

Home Page Forums Network Management ZeroShell e1000e problem with 100mb line

This topic contains 1 reply, has 0 voices, and was last updated by  Jonno 5 years, 4 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #43707

    Jonno
    Member

    Hi,

    I’ve been using Zeroshell to net balance 4 regular ADSL lines for a while and having no problems. Recently added a new 100mb fiber line which I’ve tested with a laptop and get a solid 80+mbps through.

    Am trying to hook it up to Zeroshell 2.0.RC3 using an Intel 82574L, e1000e module. I seem to get a maximum of around 5mbps if lucky (Upload seems to be closer to 60mb of a normal 80mb)

    Ethtool reports:


    Settings for ETH05:
    Supported ports: [ TP ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Half
    Port: Twisted Pair
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pumbg
    Wake-on: g
    Current message level: 0x00000007 (7)
    Link detected: yes

    Which is odd as the laptop would happily connect at 1000Mb/s Full duplex. If I force autoneg off, it will allow me to force full duplex on, but if I force 1000Mb/s it won’t connect at all. It makes no difference between Full or Half duplex 100Mb/s, both are crippled speeds.

    ifconfig reports:


    ETH05 Link encap:Ethernet HWaddr 68:05:CA:14:3D:29
    inet6 addr: fe80::6a05:caff:fe14:3d29/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:69323 errors:0 dropped:0 overruns:0 frame:0
    TX packets:45055 errors:0 dropped:0 overruns:0 carrier:0
    collisions:2858 txqueuelen:1000
    RX bytes:94556904 (90.1 Mb) TX bytes:4477788 (4.2 Mb)
    Interrupt:16 Memory:d83c0000-d83e0000

    After an almost fresh reboot, and I’m guessing the collisions may be where the problem is, but I’m not sure where to start looking to fix it.

    modinfo:


    root@zeroshell root> modinfo e1000e
    filename: /lib/modules/3.4.56-ZS/kernel/drivers/net/ethernet/intel/e1000e/e1000e.ko
    version: 1.9.5-k
    license: GPL
    description: Intel(R) PRO/1000 Network Driver
    author: Intel Corporation,
    srcversion: 79D090433A2DEF6FB5FCD00
    alias: pci:v00008086d00001503sv*sd*bc*sc*i*
    alias: pci:v00008086d00001502sv*sd*bc*sc*i*
    alias: pci:v00008086d000010F0sv*sd*bc*sc*i*
    alias: pci:v00008086d000010EFsv*sd*bc*sc*i*
    alias: pci:v00008086d000010EBsv*sd*bc*sc*i*
    alias: pci:v00008086d000010EAsv*sd*bc*sc*i*
    alias: pci:v00008086d00001525sv*sd*bc*sc*i*
    alias: pci:v00008086d000010DFsv*sd*bc*sc*i*
    alias: pci:v00008086d000010DEsv*sd*bc*sc*i*
    alias: pci:v00008086d000010CEsv*sd*bc*sc*i*
    alias: pci:v00008086d000010CDsv*sd*bc*sc*i*
    alias: pci:v00008086d000010CCsv*sd*bc*sc*i*
    alias: pci:v00008086d000010CBsv*sd*bc*sc*i*
    alias: pci:v00008086d000010F5sv*sd*bc*sc*i*
    alias: pci:v00008086d000010BFsv*sd*bc*sc*i*
    alias: pci:v00008086d000010E5sv*sd*bc*sc*i*
    alias: pci:v00008086d0000294Csv*sd*bc*sc*i*
    alias: pci:v00008086d000010BDsv*sd*bc*sc*i*
    alias: pci:v00008086d000010C3sv*sd*bc*sc*i*
    alias: pci:v00008086d000010C2sv*sd*bc*sc*i*
    alias: pci:v00008086d000010C0sv*sd*bc*sc*i*
    alias: pci:v00008086d00001501sv*sd*bc*sc*i*
    alias: pci:v00008086d00001049sv*sd*bc*sc*i*
    alias: pci:v00008086d0000104Dsv*sd*bc*sc*i*
    alias: pci:v00008086d0000104Bsv*sd*bc*sc*i*
    alias: pci:v00008086d0000104Asv*sd*bc*sc*i*
    alias: pci:v00008086d000010C4sv*sd*bc*sc*i*
    alias: pci:v00008086d000010C5sv*sd*bc*sc*i*
    alias: pci:v00008086d0000104Csv*sd*bc*sc*i*
    alias: pci:v00008086d000010BBsv*sd*bc*sc*i*
    alias: pci:v00008086d00001098sv*sd*bc*sc*i*
    alias: pci:v00008086d000010BAsv*sd*bc*sc*i*
    alias: pci:v00008086d00001096sv*sd*bc*sc*i*
    alias: pci:v00008086d0000150Csv*sd*bc*sc*i*
    alias: pci:v00008086d000010F6sv*sd*bc*sc*i*
    alias: pci:v00008086d000010D3sv*sd*bc*sc*i*
    alias: pci:v00008086d0000109Asv*sd*bc*sc*i*
    alias: pci:v00008086d0000108Csv*sd*bc*sc*i*
    alias: pci:v00008086d0000108Bsv*sd*bc*sc*i*
    alias: pci:v00008086d0000107Fsv*sd*bc*sc*i*
    alias: pci:v00008086d0000107Esv*sd*bc*sc*i*
    alias: pci:v00008086d0000107Dsv*sd*bc*sc*i*
    alias: pci:v00008086d000010B9sv*sd*bc*sc*i*
    alias: pci:v00008086d000010D5sv*sd*bc*sc*i*
    alias: pci:v00008086d000010DAsv*sd*bc*sc*i*
    alias: pci:v00008086d000010D9sv*sd*bc*sc*i*
    alias: pci:v00008086d00001060sv*sd*bc*sc*i*
    alias: pci:v00008086d000010A5sv*sd*bc*sc*i*
    alias: pci:v00008086d000010BCsv*sd*bc*sc*i*
    alias: pci:v00008086d000010A4sv*sd*bc*sc*i*
    alias: pci:v00008086d0000105Fsv*sd*bc*sc*i*
    alias: pci:v00008086d0000105Esv*sd*bc*sc*i*
    depends:
    intree: Y
    vermagic: 3.4.56-ZS SMP mod_unload modversions PENTIUMII
    parm: debug:Debug level (0=none,...,16=all) (int)
    parm: copybreak:Maximum size of packet that is copied to a new buffer on receive (uint)
    parm: TxIntDelay:Transmit Interrupt Delay (array of int)
    parm: TxAbsIntDelay:Transmit Absolute Interrupt Delay (array of int)
    parm: RxIntDelay:Receive Interrupt Delay (array of int)
    parm: RxAbsIntDelay:Receive Absolute Interrupt Delay (array of int)
    parm: InterruptThrottleRate:Interrupt Throttling Rate (array of int)
    parm: IntMode:Interrupt Mode (array of int)
    parm: SmartPowerDownEnable:Enable PHY smart power down (array of int)
    parm: KumeranLockLoss:Enable Kumeran lock loss workaround (array of int)
    parm: WriteProtectNVM:Write-protect NVM [WARNING: disabling this can lead to corrupted NVM] (array of int)
    parm: CrcStripping:Enable CRC Stripping, disable if your BMC needs the CRC (array of int)

    I believe there is a later e1000e module but I can’t run make install.

    Can anyone offer any information that may help??

    Thanks.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.