dumb question, assign dynamic IP to nic?

Home Page Forums Network Management Networking dumb question, assign dynamic IP to nic?

This topic contains 8 replies, has 0 voices, and was last updated by  defunkt 12 years, 2 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #40511

    defunkt
    Member

    i ran through this and set up a lot fo the services and actually really like zeroshell. so far ive only had one question: how can assign a dynamic IP to a NIC through the web interface. i currently have a cable modem which made me think PPPoe wasnt the solution because it is used for DSL.

    because i do not have a static IP, what would be my best choice? i feel like im overlooking somehting…

    anyone got a clue?

    #45013

    defunkt
    Member

    found it in teh faq… only supports PPPoe not cable modem…

    and i got all excited…. darn.

    well unfortuantly i cannot furhter use this until its supported…. someone email me when it is!

    #45014

    imported_fulvio
    Participant

    Zeroshell supports xDSL or cable modems which use an ethernet port (not USB). If your ISP supports the protocol PPPoE (Point to Point over ethernet) then Zeroshell is able to connect you to Internet. You just have to connect the cable modem to an ethernet interface and create a PPPoE connection. You have to configure the username and password if your Internet Provider requires it.

    Regards
    Fulvio

    #45015

    defunkt
    Member

    my ISP provides Dynamic IP addresses… not PPPoE… after doing a little research… and some extra tinkering, still could not get a NIC to grab an IP…

    any other hints for me?

    Defunkt

    #45016

    rtroian
    Member

    Hi all, I’m having the same problem posted by defunct, I have two connections here, one adsl, that is working well (using dmz zone configured at adsl router) and other at my cable modem ( dhcp with mac address auth).

    To make my Cable modem work, i’m actually using the console and calling the dhclient, after the dhcp request is ok, the route protocol receives a second default gateway and to load the web on both interfaces I just need to nat the second interface to get the web working fine!

    Now I’m in the search of how to get the interface configured via dhcp at boot time, Some sugestions?

    Regards

    rTroian

    #45017

    ADRnLn
    Member

    Any chance of getting Dynamic support built in? This would be a huge upgrade for me, the configuration options here are almost limitless…

    Thanks!

    #45018

    imported_fulvio
    Participant

    I am going to solve this problem in the the next release.

    Regards
    Fulvio

    #45019

    @fulvio wrote:

    I am going to solve this problem in the the next release.

    Regards
    Fulvio

    Hi Thx for a grat product. Next release is that beond 1.0 or is it missed in beta4?

    #45020

    Hi all!

    I have two installations where dhcp was used on the wan and it works great. Just do not assign default gateway when creating database. Enter dhclient ETHxx in rc.local. If the dhcp server provides you with gw you are on the move. You have to enable nat on the interface if you need it in your config.

    This simple issue would be great to get in the webinterface on one of the comming releases.

    #45021

    aman
    Member

    in the console, not web interface
    you can press “s”
    and input
    “dhclient ETH01”
    the ETH01 interface will get IP from your ISP, the IP as below
    ETH00:192.168.0.75
    ETH01:dynamic IP

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.