DSL auto reconnect

Home Page Forums Network Management ZeroShell DSL auto reconnect

This topic contains 6 replies, has 0 voices, and was last updated by  Phil 9 years, 8 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #40994

    Phil
    Member

    Hi there,
    this might be a stupid question but i’ll ask it anyway 😉

    I use zeroshell with a direct connection to a DSL Modem using pppoe. My provider is killing the DSL connection every 24 hours. Zeroshell doesn’t seem to notice that and fails to connect to the internet afterwards. As i want to avoid installing an additional hardware router to maintain the internet connection, is there any way to configure zeroshell to detect an interrupted pppoe connection and automatically reconnect (like any hardware router does)?

    I posted this question already in the Network part of this forum but without any replies yet so i’ll try again here. If that wrong… well… punish me 😀

    #46376

    imported_fulvio
    Participant

    I have to investigate better about this problem. I have just tried to unplug the RJ11 cable of my ADSL and then, when I have reconnected it, the PPPoE has automatically takes place.

    Regards
    Fulvio

    #46377

    Phil
    Member

    Hi there,

    i was able to track the problem down to the vmware bridge protokoll. Lessons learned, never use a beta 😉

    #46378

    chrisabc
    Member

    hi fulvio, wonder if you can help out here. my zeroshell is hosted on a dedicated machine, not using vmware or virtualbox, and is connecting directly to my adsl modem

    since changing to zeroshell about a month ago, i had a few issues with pppoe disconnection that it does not reconnect automatically. not sure if this is a configuration issue or else, but if i reconnect manually, the internet comes back again. below is log of today’s disconnection. any idea what’s happening?

    19:07:47 No response to 3 echo-requests
    19:07:47 Serial link appears to be disconnected.
    19:07:47 Connect time 9952.8 minutes.
    19:07:47 Sent 2772948247 bytes, received 2901946436 bytes.
    19:07:48 Connection terminated.
    19:07:51 Exit.
    20:17:51 pppd 2.4.3 started by root, uid 0
    20:17:51 Using interface ppp0
    20:17:51 Connect: ppp0 /dev/pts/0
    20:17:55 PAP authentication succeeded
    20:17:55 local IP address 222.64.xxx.xxx
    20:17:55 remote IP address 218.1.xxx.xxx

    #46379

    imported_fulvio
    Participant

    I am not able to reproduce the issue. In any case, you could configure the ppp0 interface as gateway in the Net Balancer, and leave the flag “Immediately restart PPPoE and 3G Mobile” to yes.

    Regards
    Fulvio

    #46380

    chrisabc
    Member

    hi fulvio, while setting up the net balancer as you suggested, i further tested and looked into the log, this is what i have noticed:

    without implementing the net balancer trick, i unplugged my RJ11 to the modem

    1. if i unplug the RJ11 myself it seems my zeroshell setup redials no problem

    2. log from PPPOE section is as below. please note “19:07:51” is when i got disconnected and zeroshell did not redial

    02:30:47 Bad TCP checksum 100
    02:30:56 message repeated 2 times
    05:38:37 Bad TCP checksum 100
    05:38:40 Bad TCP checksum 100
    05:38:46 Bad TCP checksum 100
    18:51:21 Bad TCP checksum 100
    18:51:24 Bad TCP checksum 100
    18:51:30 Bad TCP checksum 100
    19:07:51 Session 5883 terminated — received PADT from peer
    19:07:51 Sent PADT
    20:17:51 PADS: Service-Name: ”
    20:17:51 PPP session is 5919 (0x171f)
    22:28:38 Session 5919 terminated — received PADT from peer
    22:28:38 Sent PADT
    22:28:43 PADS: Service-Name: ”
    22:28:43 PPP session is 6769 (0x1a71)
    22:30:09 Session 6769 terminated — received PADT from peer
    22:30:09 Sent PADT
    22:30:14 PADS: Service-Name: ”
    22:30:14 PPP session is 6781 (0x1a7d)

    3. this is from pppoe-connection section. it confirms that zeroshell did not try to redial at “19:07:51”
    22:28:38 PPPoE connection lost; attempting re-connection.
    22:30:09 PPPoE connection lost; attempting re-connection.

    4. however, under pppd section, zeroshell does seem to recognise all the disconnections

    short description of below log from pppd section:
    “19:07:47” is when i got disconnected
    “20:17:51” is when i noticed the disconnection and reconnect manually
    “22:28:34″ is when i unplug the RJ11 myself and plugged back in at 22:28:43”

    19:07:47 No response to 3 echo-requests
    19:07:47 Serial link appears to be disconnected.
    19:07:47 Connect time 9952.8 minutes.
    19:07:47 Sent 2772948247 bytes, received 2901946436 bytes.
    19:07:48 Connection terminated.
    19:07:51 Exit.
    20:17:51 pppd 2.4.3 started by root, uid 0
    20:17:51 Using interface ppp0
    20:17:51 Connect: ppp0 /dev/pts/0
    20:17:55 PAP authentication succeeded
    20:17:55 local IP address 222.64.231.154
    20:17:55 remote IP address 218.1.0.244
    22:28:34 No response to 3 echo-requests
    22:28:34 Serial link appears to be disconnected.
    22:28:34 Connect time 130.7 minutes.
    22:28:34 Sent 506856141 bytes, received 754550013 bytes.
    22:28:35 Connection terminated.
    22:28:38 Exit.
    22:28:43 pppd 2.4.3 started by root, uid 0
    22:28:43 Using interface ppp0
    22:28:43 Connect: ppp0 /dev/pts/0
    22:28:46 PAP authentication succeeded

    so, above is what i have noticed so far, now i am implementing the net balancer trick to force for a redial

    because i cannot reproduce this error, i will have to wait for it to happen again then i can report it back, but i am confident the force redial should fix it

    just a suggestion, perhaps the force redial option can also be placed in pppoe section?

    fulvio, thanks for the great software and great help 😀

    #46381

    imported_fulvio
    Participant

    Do not forget to activate the failover monitor.

    Bye
    Fulvio

    #46382

    chrisabc
    Member

    not sure if this is lucky or unlucky, i have the same problem again today

    i am on release 1.0 beta 11 (i will update to beta 12 today)
    net balancer trick is implemented

    what i further observed is quite interesting
    * if i use the ip check under utilities, i cannot ping -> line is dead
    * if i click the “test” button in net balancer, it pings all 3 ip no problem

    unplug RJ11 and plug back doesn’t solve the issue, i have to untick the “UP” checkbox of ppp0 then tick it again to get the internet running

    when RJ11 is unplugged, i have also clicked on the “test” button, the ping fails this time. but after i plug back the RJ11, it did not redial

    for net balancer, i have the mode set to “failover”, “ICMP failover checking” enabled and “immediately restart PPPoE and 3G Mobile” set to yes

    any thoughts?

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.