Does RAIDUS server even work with tomatousb linksys routers?

Home Page Forums Network Management ZeroShell Does RAIDUS server even work with tomatousb linksys routers?

This topic contains 6 replies, has 0 voices, and was last updated by  FlashEngineer 7 years, 5 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #43265

    I setup everything according to various guides but in the log I don’t even see any attempt to connect to the radius server at all…. no requests

    So what would be the issue or this doesn’t work?

    #52179

    atheling
    Member

    At least some Linksys wifi routers work… I used to have WPA2 Enterprise setup on my WRT54G2 using the Radius server on the Zeroshell box for authentication.

    I had to drop that when my wife got a Kindle which couldn’t handle that type of authentication. Now I’m just doing WPA2 Personal which requires nothing of the Zeroshell Radius server.

    I don’t recall doing much more than following the cookbook that I found someplace on the Zeroshell site. http://www.zeroshell.net/eng/radiusdetails/ might help but that doesn’t look like the one I remember.

    I do recall that I had to look at the radius logs on the Zeroshell a few times to figure out what was going wrong. If you see nothing in the logs, then I’d double check the address the WiFi router is trying to use for the Radius server. I’m guessing if the pre-shared key doesn’t match up that will show in the logs so you’ll know about it.

    #52180

    Thanks for responding, this ZS is not easy!

    I finally fixed up most things like your NB patch which works great! thanks and now is just RAIDUS, then maybe VPN for remote access.

    I have a WRT54G2 as well, along with E-3000 and D-link router.

    On the logs I see nothing at all, it doesn’t even seem like the router is trying to authenticate with RADIUS on ZS?

    So I’m not sure what to try next?

    @atheling wrote:

    At least some Linksys wifi routers work… I used to have WPA2 Enterprise setup on my WRT54G2 using the Radius server on the Zeroshell box for authentication.

    I had to drop that when my wife got a Kindle which couldn’t handle that type of authentication. Now I’m just doing WPA2 Personal which requires nothing of the Zeroshell Radius server.

    I don’t recall doing much more than following the cookbook that I found someplace on the Zeroshell site. http://www.zeroshell.net/eng/radiusdetails/ might help but that doesn’t look like the one I remember.

    I do recall that I had to look at the radius logs on the Zeroshell a few times to figure out what was going wrong. If you see nothing in the logs, then I’d double check the address the WiFi router is trying to use for the Radius server. I’m guessing if the pre-shared key doesn’t match up that will show in the logs so you’ll know about it.

    #52181

    thresh
    Member

    It definitely does work… I have sucesfully had WRT54GLs, E3000s, RT-n16s, and the g asus router that supports mlppp all work with Radius Authentication and built in LDAP via Tomato… can you walk me through your procedure.. have you set up radius authenticated clients and radius proxy server for the tomatos

    #52182

    @thresh wrote:

    It definitely does work… I have sucesfully had WRT54GLs, E3000s, RT-n16s, and the g asus router that supports mlppp all work with Radius Authentication and built in LDAP via Tomato… can you walk me through your procedure.. have you set up radius authenticated clients and radius proxy server for the tomatos

    Sure, I just followed some of those guides on the net, but here is the ballpark. I’m just trying to do simple PEAP for now

    -First, created new trusted CA, exported that to .DER file to use on clients.
    -Enabled the RADIUS
    -Added authorized clients, so my router(s) – e3000’s IP address, lets say it’s .105 of the subnet
    -Added a user, myself with password.

    -On tomato firmware router E-3000, wireless AP 2.4Ghz I changed to WPA2 enterprise, AES encryption, Radius server: zeroshell’s admin IP, and port # 1812

    -Clients, I imported the .DER file and put it in the trusted certificates.
    -setup the wireless AP properties: Select Enterprise/radius
    -Set computer authentication, prompt for user/pass
    -PEAP, selected the certificate I imported
    -set EAP-MSCHAP v2

    Then now I try to connect to my router and what happens is I get prompt user/pass then I enter it and it can’t connect, error, doesn’t work etc.

    I check zeroshell, there’s nothing in the RADIUSD logs, just says waiting for request…

    #52183

    atheling
    Member

    Not an expert enough on Radius authentication to really help. As I said I followed a cookbook I found. Just did a web search and maybe it was this one: http://www.linuxplanet.com/linuxplanet/tutorials/6737/1/

    Glad to hear my net balance/QoS patch seems to be working for you. I do wish Fulvio would put it in his release….

    #52184

    @atheling wrote:

    Not an expert enough on Radius authentication to really help. As I said I followed a cookbook I found. Just did a web search and maybe it was this one: http://www.linuxplanet.com/linuxplanet/tutorials/6737/1/

    Glad to hear my net balance/QoS patch seems to be working for you. I do wish Fulvio would put it in his release….

    Yes but your patch is easy enough to use and install 🙂

    NB is great, when using my newsgroup downloading documentaries I can get around 50mbps or about ~ 6MB/sec

    #52185

    I think there’s something wrong with my windows client setup, it seems RADIUS functions fine since freeradius is easy enough to implement, i’ve done some more testing.

    Is there any better guides in setting up the clients on windows using EAP-TLS?

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.