DNS woes

Home Page Forums Network Management ZeroShell DNS woes

This topic contains 2 replies, has 0 voices, and was last updated by  baboo 10 years, 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #41481

    baboo
    Member

    I cannot get DNS working. I am not sure if my problem is on zeroshell or not. So I am showing my config to see if anything jumps out to more knowledgeable people. I have a DNS server behind Zeroshell router connected to dsl modem.

    Zeroshell config:
    uses PP0E and is connected.
    Zeroshell is gateway
    WAN nic: 67.xx.xx.xx
    Internal nic: 192.168.0.2

    My DNS server:
    Internal nic: 192.168.0.10
    External IP: 67.xx.xx.xx

    I did the following with Zeroshell:
    DNS Fordwarders set to:
    ANY domain server 67.xx.xx.xx

    I cannot ping public DNS IP 67.xx.xx.xx
    dig and nslookup return message that can not connect to server.

    I really could use some input.

    thanks

    #47633

    bbozo
    Member

    Zeroshell config:
    uses PP0E and is connected.
    Zeroshell is gateway
    WAN nic: 67.xx.xx.xx
    Internal nic: 192.168.0.2

    OK

    My DNS server:
    Internal nic: 192.168.0.10
    External IP: 67.xx.xx.xx

    This part is a bit confusing. Is your DNS going out thru ZS or does it have it’s own internet connection.
    If it’s going thru ZS then I thik you should make your DNS make all DNS resolutions.
    DNS setup:
    ip: 192.168.0.10
    gtw: ZS ip
    DNS: ISP DNS or/and localhost
    forwarders: ISPDNS

    I did the following with Zeroshell:
    DNS Fordwarders set to:
    ANY domain server 67.xx.xx.xx

    ZS should forward it’s requests to your DNS and/or ISP-s

    Check if NAT is set on ZS.

    Hope this helps

    #47634

    baboo
    Member

    This part is a bit confusing. Is your DNS going out thru ZS or does it have it’s own internet connection.

    My DNS is going out thru ZS.

    You say to use my DNS for resolution.

    So, if I am understanding you, DNS ip: 192.168.0.10
    ZS ip for gtw: 67.xx.xx.xx ?

    ZS should forward it’s requests to your DNS and/or ISP-s

    Meaning to the internal ip of DNS server?

    Yes NAT is set.

    thanks for your reply. all info helps 🙂

    thanks

    #47635

    bbozo
    Member

    PCs setup
    ip: 192.168.0.x
    gtw: 192.168.0.2 ZS
    DNS: 192.168.0.10

    DNS server
    ip:192.168.0.10
    gtw:192.168.0.2
    DNS:192.168.0.10
    FORWARDERS:192.168.0.2

    (initiali I suggested you to put ISP DNS as forwarers, that should work too)
    Ofcourse it all depends on your DNS server setup…..
    And the confusing part about your DNS server is external IP?????

    ZS
    internal ip: 192.168.0.2
    external ip: ISP assigned
    gtw: ISP assigned
    forwarders: ISP DNS servers (it should be two of them)
    you can use DNS lookup in ZS to find ISPs DNS server names an IPs so you do not have to use ANY option in forwarders.

    This setup is working.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.