dns problem

Home Page Forums Network Management Networking dns problem

This topic contains 5 replies, has 0 voices, and was last updated by  pescavasimulo 7 years, 4 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #42835

    Sorry for the stupid question. I’m trying to to use zeroshell as a router. I installed it without any problem and any computer within the lan can browse everywhere if I use the absolute IP addresses. I did not find any place in the web configuration page where I can provide the ip address of the DNS server. It is not possible to access the resolv.conf to put the number by hand. I made many test but unsuccesfully. I cannot resolve the names even within the shell of zeroshell. any ping gives me back: unknown host.

    I checked the forum but I did not find anything that helped me.

    Thanks in advance

    Alessandro

    #51529

    SysEngBD
    Member

    You can set up the DNS forwarder:

    Click “DNS” on the Left the “Forwarders” at the top.

    Plug in domain and server pairs.

    I use the domain ANY and OpenDNS servers at 208.67.222.222 and 208.67.220.220 but you can use whatever you want. This will tell Zeroshell which DNS servers to use. And if you set up DHCP and your clients are pointing to your Zeroshell box then they’ll use Zeroshell for DNS which will in turn use what you specify here.

    Cheers

    #51530

    Thanks for your answer.
    Actually I tried to use the port forwarding but I did not succeed. I did the following:

    imagine the real DNS server is 1.2.3.4
    the external address of zeroshell is 1.2.3.50
    the internal address of zeroshell is 192.168.2.1

    within the DNS page of zero shell I activated the port forwarding as:

    ANY 1.2.3.4

    and

    in the clients (192.168.2.2) DNS configuration I put 1.2.3.4

    It did not work. I co not understand why.

    Where am I wrong??

    Alessandro

    #51531

    SysEngBD
    Member

    My guess is that you may have a connectivity issue with that DNS server (or in general).

    If the client is set up as such:
    IP: 192.168.2.2
    DNS: 1.2.3.4
    Default Gateway: 192.168.2.1 (Zeroshell internal)

    The Zeroshell box should have a route to 1.2.3.4 (if say the DNS server is internal) or a default gateway of its own set up (if the DNS server is external plus this is beneficial if you’re intending on internet access).

    Some examples:

    If the DNS Server – 1.2.3.4 is an external DNS server the process would go something like this:

    1) Client sees that it needs to resolve an address, checks the DNS server address in its settings, notices the DNS server isn’t on its subnet (not local to it), and sends the request to its default gateway (the Zeroshell box).

    2)The Zeroshell box would then look up the route to 1.2.3.4, seeing as that is not a local address to the Zeroshell box it’ll send it out through it’s default gateway.

    3) Beyond this a similar process (route lookup and forwarding) occurs until the DNS server is contacted and the reply comes back to the client

    If the DNS server is internal you’d want to make sure Zeroshell knows how to get there i.e.:

    1) If the DNS server is attached to Zeroshell then Zeroshell should have and interface in the same subnet that is attached to the DNS server (like 1.2.3.50 in your example although you refer to this as the external interface). In that case a route is automatically added since it is connected and local to Zeroshell.

    2) If the DNS server is attached elsewhere, Zeroshell will need a route to that network in its routing table (found under “Router” to the left of the GUI)

    Hope this is helpful. If the DNS server is external (on the internet) make sure you’ve set up a Default Gateway for Zeroshell and that is connected to a live internet connection. Also, I’d ensure the internet connection interface has NAT on it (Also under “Router” on the left menu).

    Cheers

    #51532

    THANKS A LOT FOR YOUR PROMPT ANSWER!!!

    THIS WEEK END I’LL STUDY IT AND LET YOU KNOW IF I PROGRESS!!!

    ALESSANDRO

    #51533

    Thanks!

    I eventually undertood my mistake and now it works. I put the real DNS address in the resolv.conf of the client while the internal address of zeroshell had to be included.

    Thanks again!!!!!

    Alessandro

    #51534

    Anonymous
    Member

    DELETED

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.