Disable admin ssh login menu

Home Page Forums Network Management ZeroShell Disable admin ssh login menu

This topic contains 1 reply, has 0 voices, and was last updated by  tgunr 9 years, 2 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #42141

    tgunr
    Member

    Is there a safe way to disable the menu on a ssh login so that I can just ssh straight into my shell without having to stop and enter ‘S’ everytime?

    #49378

    atheling
    Member

    If you only want it to last until the next reboot, then get into the shell prompt and enter:

    root@zeroshell root> chsh -s /bin/bash

    I do this when I want to mount the Zeroshell’s disk on my Macintosh’s desktop using Macfuse and Macfusion and the ssh filesystem. Makes writing patch files to the box a lot easier.

    If you want to make it permanent, you could put the same command into either pre-boot or post-boot scripts.

    root@zeroshell root> chsh -help
    chsh: invalid option — ‘h’
    Usage: chsh [-s shell] [name]

    #49379

    tgunr
    Member

    Great tip, thanks! I will making it permanent 🙂

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.