DHCP server serving several subnets

Home Page Forums Network Management ZeroShell DHCP server serving several subnets

This topic contains 2 replies, has 0 voices, and was last updated by  Cyberbear 12 years, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #40501

    Cyberbear
    Member

    I have tried this server and it works perfectly except one thing.

    We have several subnets connected throu a router which uses DHCP-relay so we can dynamicaly serve IP-addresses to our subnets.
    When i configured this on a Windows Server I could just create scopes with networks which it didn’t have an IP-adress on.

    When I try to do this on ZeroShell it just tells me that it needs an IP-address on that network.

    Is this a bug or is it a limit in the system?

    Regards
    Gustaf /Sweden

    #44966

    imported_fulvio
    Participant

    ZeroShell uses Internet Systems Consortium DHCP Server V3.0.4 and I think
    it does not work if there isn’t an IP included in the subnet you configure. The error message is:

    Not configured to listen on any interfaces!

    Regards
    Fulvio

    #44967

    Cyberbear
    Member

    It did work after all.

    It said that it wasn’t working but it worked anyway.

    Thank you for an excelent product!!! 😀

    #44968

    Borage
    Member

    The dhcpd server must be configured to listen on a network interface.

    Check that you have this file:
    /etc/sysconfig/dhcpd

    # Command line options:
    DHCPDARGS=”eth1 eth2″

    Replace eth1 & eth2 with your configuration.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.