dhcp.conf

Home Page Forums Network Management ZeroShell dhcp.conf

This topic contains 1 reply, has 0 voices, and was last updated by  flaxx 10 years, 9 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #40998

    flaxx
    Member

    Hi,

    I don’t usually ask for help unless I’ve really tried to resolve an issue. I don’t know linux that well but I basically got pretty acquainted with it trying to resolve this problem, and only partially succeeded.

    My ZeroShell router needs the followed added to the dhcp.conf file:

    allow booting;
    allow bootp;

    In addition, under two of the static network cards, I need to put in:

    next-server 192.168.1.100;
    filename "/pxelinux.0";

    Every time I modify the dhcp.conf file, it is overwritten when I restart or disable/re-enable the service. The only way I could PARTIALLY fix the problem is by editing the file: /kerbynet.cgi/scripts/dhcp_configfile
    after the line

    "echo " fixed-address ${IP};"

    I added:

    echo " next-server 192.168.1.100;"
    echo " filename "/pxelinux.0";"

    and then after the line

    "ignore client-updates;"

    I added:

    allow booting;
    allow bootp;

    However, even this script is overwritten every time the router is rebooted (because I think it comes from the ISO).

    How do we modify the dhcp.conf file and make it stick? Can the web-interface perhaps have a place to put in additional options for the dhcp.conf file? Any help would be greatly appreciated because as is, I have to keep putting that in whenever the router is rebooted (which hopefully won’t be often, but it’s not a permanent solution). Thanks!

    #46401

    imported_fulvio
    Participant

    Copy your version of the file /root/kerbynet.cgi/scripts/dhcp_configfile in the directory /Database.
    After that add in the file /etc/rc.pre the line:

    cp /Database/dhcp_configfile /root/kerbynet.cgi/scripts/

    Regards
    Fulvio

    #46402

    flaxx
    Member

    Thanks a lot Fulvio! I really appreciate the prompt response. It worked perfectly! Thanks again and keep up the great work!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.