Default gateway? Can no longer set by interface?

Home Page Forums Network Management Networking Default gateway? Can no longer set by interface?

This topic contains 2 replies, has 2 voices, and was last updated by  Ian Harrison 3 months, 1 week ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #64273

    arfon
    Participant

    In the older versions of Zeroshell, you could set the default gateway by IP or Interface. Now, it’s only IP. How do you ensure the Default Gateway is correct when your ISP gives you a new IP?

    (I want my DGW to always be on eth1)

    • This topic was modified 3 months, 2 weeks ago by  arfon.
    #64279

    arfon
    Participant

    The answer is to enable Net Balancer and set the DGW there.

    #64312

    Ian Harrison
    Participant

    Looking for a little help setting up the internet connection. I have got several things working but am not able to get through to the internet.
    Running on a core i5 box with 10 Ethernet interfaces, 9 are GB and one 100M interface (ETH01) used for the ADSL 2 router (Netgear D7000). All other NICs (ie not ETH01) are Bridged (BRIDGE00) to a single network 10.0.0.0/24 giving me about 250 IPs for my network.
    The ZS box is 10.0.0.1, so the Gatway, and DNS for my network is also 10.0.0.1 and DHCP does appear to by setting these all OK to the clients on the Network.
    ETH01 has been set as a PPPoE port (PPP00), and the Modem (now set to Modem only mode) appears to be responding correctly with three white LEDS (Power, Internet, DSL all connected).
    But no clients (wired, wireless, W10, Droid) can access the internet…the all show icons for no internet.
    NAT routing table is (NB VPN is not enabled at present)

    Destination Netmask Type Metric Gateway Interface Flags State Source
    DEFAULT GATEWAY 0.0.0.0 Net 0 10.0.0.1 BRIDGE00 UG Up Static
    DEFAULT GATEWAY 0.0.0.0 Net 0 10.0.0.1 BRIDGE00 UG Up Static
    10.0.0.0 255.255.255.0 Net 0 none BRIDGE00 U Up Auto
    192.168.250.0 255.255.255.0 Net 0 none VPN99 U Up Auto

    I would expect to see somewhere in the interface the IP address allocated to ETH01 by my ISP (this changes every time the ADSL interface is restarted) but I have not found it. On the Linux Shell interface (on the ZS has a monitor for moment), there is a IP6 address, but so do the active NICs on Bridge00.
    So what am I missing to make this connection between the Gateway and the Modem…and how can I see the IP address allocated through the Modem to ETH01 (gives me confidence it is working)?
    I followed setup instructions from this site for a SOHO network (albeit 2011) and NAT, both were useful.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.